Virtual Memory
Posted in 2000
Howard Jones — — source: Informix-list mailing list archive (1991-1998)
We are running Informix 7.3 on HPux 11 On a system with 6Gb available memory, I am trying to increase the SHMVIRTSIZE. It is currently set to 2000000 kb ( 2 Gb ). Initially I tried increasing by 500000 kb this resulted in informix failing to initialise with error "size of resident + virtual segments 943613032 + 4294705152 > 5120000000 total allowed by configuration parameter SHMTOTAL" As can be seen SHMTOTAL is set to 5Gb. My question is why is informix trying to allocate 4 Gb of SHMVIRTSIZE when all I am asking for is 2.5 Gb. Note, I have tried various settings of SHMVIRTSIZE between 2 Gb & 2.5Gb and Informix seems to want to allocate 4Gb for any value of SHMVIRTSIZE over 2096000 kb. Cheers, Howard