ontape level 0 backup
Posted in 1999
Topics: Backup & Restore, Storage & Space Management
I'm setting up a new system and I was trying to run a test level 0 backup of
my database using ontape. Whenever I run it, it will ask for the tape to
mount, do a blocks worth of I/O, and then abort with the following error:
shmat: [22]: operating system error
The informix log reads as follows:
17:03:11 Level 0 Archive started on rootdbs, plogdbs_01, llogdbs_01,
datadbs_01
, datadbs_02, datadbs_03, datadbs_04, datadbs_05, datadbs_06, indxdbs_01,indxdb
s_02, reptdbs_01
17:03:18 Archive on rootdbs, plogdbs_01, llogdbs_01, datadbs_01,
datadbs_02, da
tadbs_03, datadbs_04, datadbs_05, datadbs_06, indxdbs_01, indxdbs_02,
reptdbs_01
ABORTED.
17:03:18 Aborted by client.
I've never seen this error nor do I have this problem on my current
production server. Any ideas?
Are you hitting a shared memory kernel limit? Worth checking
$INFORMIXDIR/release perhaps?
Weaver, Bill wrote in message <81uvo5$1r7$1@news.xmission.com>...
>
>I'm setting up a new system and I was trying to run a test level 0 backup
of
>my database using ontape. Whenever I run it, it will ask for the tape to
>mount, do a blocks worth of I/O, and then abort with the following error:
>
>shmat: [22]: operating system error
>
>The informix log reads as follows:
>
>17:03:11 Level 0 Archive started on rootdbs, plogdbs_01, llogdbs_01,
>datadbs_01
>, datadbs_02, datadbs_03, datadbs_04, datadbs_05, datadbs_06, indxdbs_01,>indxdb
>s_02, reptdbs_01
>17:03:18 Archive on rootdbs, plogdbs_01, llogdbs_01, datadbs_01,
>datadbs_02, da
>tadbs_03, datadbs_04, datadbs_05, datadbs_06, indxdbs_01, indxdbs_02,
>reptdbs_01
> ABORTED.
>17:03:18 Aborted by client.>
>I've never seen this error nor do I have this problem on my current
>production server. Any ideas?
My level 0 backup also aborts with the following errorlog:
1999-11-30 11:36:20 202 0 onbar -b -L 0
1999-11-30 11:36:27 202 0 ERROR: Unable to start the DB/BLOBspace
backup: buc_fe.c : Archive API processing failed at line 234 for
msgtype.
Have you seen this error?
My server is IDS UDO 9.14TC5 (NT sp3)
Karl Johan Grøttum
"Weaver, Bill" wrote:
>
> I'm setting up a new system and I was trying to run a test level 0 backup of
> my database using ontape. Whenever I run it, it will ask for the tape to
> mount, do a blocks worth of I/O, and then abort with the following error:
>
> shmat: [22]: operating system error
>
> The informix log reads as follows:
>
> 17:03:11 Level 0 Archive started on rootdbs, plogdbs_01, llogdbs_01,
> datadbs_01
> , datadbs_02, datadbs_03, datadbs_04, datadbs_05, datadbs_06, indxdbs_01,> indxdb
> s_02, reptdbs_01
> 17:03:18 Archive on rootdbs, plogdbs_01, llogdbs_01, datadbs_01,
> datadbs_02, da
> tadbs_03, datadbs_04, datadbs_05, datadbs_06, indxdbs_01, indxdbs_02,
> reptdbs_01
> ABORTED.
> 17:03:18 Aborted by client.>
> I've never seen this error nor do I have this problem on my current
> production server. Any ideas?
What is the O/S on which IDS is on?
If HP-UX, set environment variable 'SINGLESEG_OFF=1' and restart IDS and, retry
ontape.
Wish this helps you.
"Weaver, Bill" wrote:
> I'm setting up a new system and I was trying to run a test level 0 backup of
> my database using ontape. Whenever I run it, it will ask for the tape to
> mount, do a blocks worth of I/O, and then abort with the following error:
>
> shmat: [22]: operating system error
>
> The informix log reads as follows:
>
> 17:03:11 Level 0 Archive started on rootdbs, plogdbs_01, llogdbs_01,
> datadbs_01
> , datadbs_02, datadbs_03, datadbs_04, datadbs_05, datadbs_06, indxdbs_01,> indxdb
> s_02, reptdbs_01
> 17:03:18 Archive on rootdbs, plogdbs_01, llogdbs_01, datadbs_01,
> datadbs_02, da
> tadbs_03, datadbs_04, datadbs_05, datadbs_06, indxdbs_01, indxdbs_02,
> reptdbs_01
> ABORTED.
> 17:03:18 Aborted by client.>
> I've never seen this error nor do I have this problem on my current
> production server. Any ideas?
It is probably caused. (only in my opinion)...
by either not enough TEMP space, or not enough Log
space...
On Mon, 29 Nov 1999 17:17:17 -0500, "Weaver, Bill"
<bweaver@fscorp.com> wrote:
>
>I'm setting up a new system and I was trying to run a test level 0 backup of
>my database using ontape. Whenever I run it, it will ask for the tape to
>mount, do a blocks worth of I/O, and then abort with the following error:
>
>shmat: [22]: operating system error
>
>The informix log reads as follows:
>
>17:03:11 Level 0 Archive started on rootdbs, plogdbs_01, llogdbs_01,
>datadbs_01
>, datadbs_02, datadbs_03, datadbs_04, datadbs_05, datadbs_06, indxdbs_01,>indxdb
>s_02, reptdbs_01
>17:03:18 Archive on rootdbs, plogdbs_01, llogdbs_01, datadbs_01,
>datadbs_02, da
>tadbs_03, datadbs_04, datadbs_05, datadbs_06, indxdbs_01, indxdbs_02,
>reptdbs_01
> ABORTED.
>17:03:18 Aborted by client.>
>I've never seen this error nor do I have this problem on my current
>production server. Any ideas?
Senior Systems Engineer(A little of this,
A little of that...
mostly INFX)
VF Corp
> >I'm setting up a new system and I was trying to run a test level 0 backup
of
> >my database using ontape. Whenever I run it, it will ask for the tape to
> >mount, do a blocks worth of I/O, and then abort with the following error:
> >
> >shmat: [22]: operating system error
Look at your tape setup closely. The problem is probably there. Also, check
TAPEBLKSIZE in onconfig and if you have enough temp space.
--
-------------------------------------------------
With best regards, Yuri Dovgart
SAP R/3, Informix technical consultant,
Informix Certified Professional,
Senior System Consultant
System Architecture and High Availability Systems,
'Telecominvest' company
Email y_dovgart@tci.ukrtel.net
ICQ 39284285