error message - unable to open input file 's'
Posted in 1999
Topics: Storage & Space Management, Logging & Checkpoints
This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.
------_=_NextPart_001_01BF2630.3B0A220E
Content-Type: text/plain;
charset="iso-8859-1"
I am getting these error messages with "oninit -y", any ideas....
thanks in advance... john
Informix Dynamic Server Version 7.31.UC2
DataGeneral 3650 UX
...
Initializing log/checkpoint information...succeeded
Opening primary chunks...succeeded
Opening mirror chunks...succeeded
Initializing dbspaces...succeeded
Validating chunks...succeeded
Initialize Async Log Flusher...succeeded
Forking btree cleaner...succeeded
Initializing DBSPACETEMP list
Unable to open input file 's'
Unable to open input file 'c'
Unable to open input file 's'
Unable to open input file 'c'
Unable to open input file 's'
Unable to open input file 'c'
Checking database partition index...succeeded
Checking location of physical log...succeeded
...
------_=_NextPart_001_01BF2630.3B0A220E
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Diso-8859-1">
<META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
5.5.2448.0">
<TITLE>error message - unable to open input file 's'</TITLE>
</HEAD>
<BODY>
<UL>
<P><FONT SIZE=3D2 FACE=3D"Times New Roman">I am getting these error =
messages with "oninit -y", any ideas....</FONT><FONT =
FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">thanks in advance... =
john</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Informix Dynamic Server =
Version 7.31.UC2</FONT><BR>
<FONT SIZE=3D2 FACE=3D"Times New Roman">DataGeneral 3650 UX</FONT><FONT =
FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">...</FONT><FONT =
FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Initializing =
log/checkpoint information...succeeded</FONT><FONT FACE=3D"Times New =
Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Opening primary =
chunks...succeeded</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Opening mirror =
chunks...succeeded</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Initializing =
dbspaces...succeeded</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Validating =
chunks...succeeded</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Initialize Async Log =
Flusher...succeeded</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Forking btree =
cleaner...succeeded</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Initializing DBSPACETEMP =
list</FONT><FONT FACE=3D"Times New Roman"><BR>
<B></B></FONT><B><FONT SIZE=3D2 FACE=3D"Times New Roman">Unable to open =
input file 's'</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Unable to open input =
file 'c'</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Unable to open input =
file 's'</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Unable to open input =
file 'c'</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Unable to open input =
file 's'</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Unable to open input =
file 'c'</FONT><FONT FACE=3D"Times New Roman"> </FONT></B>
<BR><FONT SIZE=3D2 FACE=3D"Times New Roman">Checking database partition =
index...succeeded</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">Checking location of =
physical log...succeeded</FONT><FONT FACE=3D"Times New Roman"><BR>
</FONT><FONT SIZE=3D2 FACE=3D"Times New Roman">...</FONT><FONT =
FACE=3D"Times New Roman"> </FONT>
</P>
</UL>
</BODY>
</HTML>
------_=_NextPart_001_01BF2630.3B0A220E--
"Weimer, John - CHARLOTTE" wrote:
> I am getting these error messages with "oninit -y", any ideas....
> thanks in advance... john
> Informix Dynamic Server Version 7.31.UC2
> DataGeneral 3650 UX
> ...
> Initializing log/checkpoint information...succeeded
> Opening primary chunks...succeeded
> Opening mirror chunks...succeeded
> Initializing dbspaces...succeeded
> Validating chunks...succeeded
> Initialize Async Log Flusher...succeeded
> Forking btree cleaner...succeeded
> Initializing DBSPACETEMP list
> Unable to open input file 's'
> Unable to open input file 'c'
> Unable to open input file 's'
> Unable to open input file 'c'
> Unable to open input file 's'
> Unable to open input file 'c'
> Checking database partition index...succeeded
> Checking location of physical log...succeeded
> ...
First please do not post HTML or MIME, adjust your mailer to post plain
text. Many readers cannot handle HTML or MIME. Now, what is the value
of the DBSPACETEMP environment and ONCONFIG parameters? Looks like it
may be something like: DBSPACETEMP=s:c:s:c:s:c. Also post the contents
of your ONCONFIG file and the output from export or set (whichever
produces vars and values in your shell, ie export for ksh, set for sh).
Art S. Kagel
I get this message when my server crashes !
"Art S. Kagel" wrote:
>
> "Weimer, John - CHARLOTTE" wrote:
>
> > I am getting these error messages with "oninit -y", any ideas....
> > thanks in advance... john
> > Informix Dynamic Server Version 7.31.UC2
> > DataGeneral 3650 UX
> > ...
> > Initializing log/checkpoint information...succeeded
> > Opening primary chunks...succeeded
> > Opening mirror chunks...succeeded
> > Initializing dbspaces...succeeded
> > Validating chunks...succeeded
> > Initialize Async Log Flusher...succeeded
> > Forking btree cleaner...succeeded
> > Initializing DBSPACETEMP list
> > Unable to open input file 's'
> > Unable to open input file 'c'
> > Unable to open input file 's'
> > Unable to open input file 'c'
> > Unable to open input file 's'
> > Unable to open input file 'c'
> > Checking database partition index...succeeded
> > Checking location of physical log...succeeded
> > ...
>
> First please do not post HTML or MIME, adjust your mailer to post plain
> text. Many readers cannot handle HTML or MIME. Now, what is the value
> of the DBSPACETEMP environment and ONCONFIG parameters? Looks like it
> may be something like: DBSPACETEMP=s:c:s:c:s:c. Also post the contents
> of your ONCONFIG file and the output from export or set (whichever
> produces vars and values in your shell, ie export for ksh, set for sh).
>
> Art S. Kagel
Naresh Chainani wrote:
>
> I get this message when my server crashes !
Interesting, since these are startup traced enabled by the -v flag to
oninit. So, what message is that, Naresh? Please start a post with
details or open an Informix support case.
Art S. Kagel
> "Art S. Kagel" wrote:
> >
> > "Weimer, John - CHARLOTTE" wrote:
> >
> > > I am getting these error messages with "oninit -y", any ideas....
> > > thanks in advance... john
> > > Informix Dynamic Server Version 7.31.UC2
> > > DataGeneral 3650 UX
> > > ...
> > > Initializing log/checkpoint information...succeeded
> > > Opening primary chunks...succeeded
> > > Opening mirror chunks...succeeded
> > > Initializing dbspaces...succeeded
> > > Validating chunks...succeeded
> > > Initialize Async Log Flusher...succeeded
> > > Forking btree cleaner...succeeded
> > > Initializing DBSPACETEMP list
> > > Unable to open input file 's'
> > > Unable to open input file 'c'
> > > Unable to open input file 's'
> > > Unable to open input file 'c'
> > > Unable to open input file 's'
> > > Unable to open input file 'c'
> > > Checking database partition index...succeeded
> > > Checking location of physical log...succeeded
> > > ...
> >
> > First please do not post HTML or MIME, adjust your mailer to post plain
> > text. Many readers cannot handle HTML or MIME. Now, what is the value
> > of the DBSPACETEMP environment and ONCONFIG parameters? Looks like it
> > may be something like: DBSPACETEMP=s:c:s:c:s:c. Also post the contents
> > of your ONCONFIG file and the output from export or set (whichever
> > produces vars and values in your shell, ie export for ksh, set for sh).
> >
> > Art S. Kagel
"Art S. Kagel" <kagel@bloomberg.net> writes:
> Naresh Chainani wrote:
> >
> > I get this message when my server crashes !
>
> Interesting, since these are startup traced enabled by the -v flag to
> oninit. So, what message is that, Naresh? Please start a post with
> details or open an Informix support case.
I've got the same, but not on crashes.
(IDS 7.31 UC2 on HP-UX 10.20)
Haven't had the time to look into it yet, but the message(s) appear
both on init and after several days -periodic of cource...
Doesn't give me problems though.
Thomas
Hi,
You are right Art, I need to give some details on what I actually
wanted to say.
When I say that "I get this message when my server crashes" - what I
meant was that whenever I have a case wherein a
server-crash/assertion-failure is reported, an af.<num> file is dumped
to /tmp & from the session from which my oninit was started, I get a
message, unable to open file 's'/'c'.
The context in which I said the above quoted sentence was in response
to your suspicion on DBSPACETEMP onconfig parameter being set to s:c:s:c
... & hence, my posting was in reponse to your posting & NOT the
original posting by John. In effect what my reply meant was -
There are 2 possible causes when such an message can occur ->
i) DBSPACETEMP=s:c:s:c [Suggested by Art]
Oh, Oh, I have something more on this, I modified my DBSPACETEMP
setting to reflect the above value & the server initialization (oninit
-ivy) ran w/o complaining, but in my online.log message file I got ->
11:59:15 Informix Dynamic Server Version 7.32.UN192 Software SerialNumber RDS#N000000
11:59:25 Informix Dynamic Server Initialized -- Complete DiskInitialized.
11:59:26 Warning: Invalid dbspace 's' listed in DBSPACETEMP.
11:59:26 Warning: Invalid dbspace 'c' listed in DBSPACETEMP.
11:59:26 Warning: Invalid dbspace 's' listed in DBSPACETEMP.
11:59:26 Warning: Invalid dbspace 'c' listed in DBSPACETEMP.
11:59:26 Checkpoint Completed: duration was 0 seconds.
11:59:26 Checkpoint loguniq 1, logpos 0xa0
So I think it rules out this possibility, isn't it ?
ii) Assertion Failure/ Server Crash [Suggested by Naresh]
I have a script which replicates this scenario & will mail it on
request.
Till now, I never have had an assertion failure during initialization on
Solaris platform across various Informix Server versions.
Hey wait, I have something more on the message we are getting, which I
just came to know about :
Whenever there is an assertion failure the server calls a script,
described by SYSALARMPROGRAM onconfig parameter, & is generally set to
$INFORMIXDIR/etc/evidence.sh, which is called when the server encounters
an Assertion Failure.
This file has 2 lines because of which the message "unable to open file"
comes. A way to avoid this will be change the foll 2 lines of
evidence.sh script
FROM
ev_pretty $ONSTAT -g smb s
ev_pretty $ONSTAT -g smb c
TO the foll one line
ev_pretty $ONSTAT -g smb
FOR
7.31x family servers only.
The s & c options are required for 9.x family of servers.
Please note that changing evidence.sh does not anyway fix the AF, it
just stops a disturbing message from coming to stdout. In the meanwhile,
I shall look to correct this evidence.sh file permanantly.
Do get back if more clarifications are needed.
Thanks & regards,
Naresh
"Art S. Kagel" wrote:
>
> Naresh Chainani wrote:
> >
> > I get this message when my server crashes !
>
> Interesting, since these are startup traced enabled by the -v flag to
> oninit. So, what message is that, Naresh? Please start a post with
> details or open an Informix support case.
>
> Art S. Kagel
>
> > "Art S. Kagel" wrote:
> > >
> > > "Weimer, John - CHARLOTTE" wrote:
> > >
> > > > I am getting these error messages with "oninit -y", any ideas....
> > > > thanks in advance... john
> > > > Informix Dynamic Server Version 7.31.UC2
> > > > DataGeneral 3650 UX
> > > > ...
> > > > Initializing log/checkpoint information...succeeded
> > > > Opening primary chunks...succeeded
> > > > Opening mirror chunks...succeeded
> > > > Initializing dbspaces...succeeded
> > > > Validating chunks...succeeded
> > > > Initialize Async Log Flusher...succeeded
> > > > Forking btree cleaner...succeeded
> > > > Initializing DBSPACETEMP list
> > > > Unable to open input file 's'
> > > > Unable to open input file 'c'
> > > > Unable to open input file 's'
> > > > Unable to open input file 'c'
> > > > Unable to open input file 's'
> > > > Unable to open input file 'c'
> > > > Checking database partition index...succeeded
> > > > Checking location of physical log...succeeded
> > > > ...
> > >
> > > First please do not post HTML or MIME, adjust your mailer to post plain
> > > text. Many readers cannot handle HTML or MIME. Now, what is the value
> > > of the DBSPACETEMP environment and ONCONFIG parameters? Looks like it
> > > may be something like: DBSPACETEMP=s:c:s:c:s:c. Also post the contents
> > > of your ONCONFIG file and the output from export or set (whichever
> > > produces vars and values in your shell, ie export for ksh, set for sh).
> > >
> > > Art S. Kagel
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"