Re: KAIO error on a HP-UX 10.20
Posted in 2000
In article <8fv3ov$p7i$1@taliesin2.netcom.net.uk>, Neil Truby
<ntruby@netcomuk.co.uk> writes
>There's a performance bug which means that you should not use kaio on HP-UX
>10.20 with v7.24 UC7 or lower (unless you want to be fired, I suppose!).
>
>On later version it's fines. I run a production server with v7.31 UC5 on
>HP-UX 10.20 with kaio, no problem.
>
>I don't know what your problem below is, but I'd start with kernel parameter
>settings as my prime suspect.
>
>Neil
>Glenn Cummings wrote in message <8ftoom$hhe$1@swifty.westend.com>...
>>Hi,
>>
>>we try to activate KAIO on a HP-UX 10.20, and get the following error:
>>
>>16:05:51 hpkaioaddseg: ASYNC_ADDSEG failed, errno = 14
>>16:05:52 Assert Failed: kaiothread() ERROR
>>16:05:52 Informix Dynamic Server Version 7.31.UC4
>>16:05:52 Who: Session(0, @, 0, 0)
>> Thread(30, kaio, 0, 5)
>> File: kaio.c Line: 2121
>>16:05:52 stack trace for pid 23081 written to
>>/usr/informix/dump.d/af.406043f
>>16:06:06 See Also: /usr/informix/dump.d/af.406043f, shmem.406043f.0
>>16:06:23 kaio.c, line 2121, thread 30, proc id 23081, kaiothread() ERROR.
>>16:06:23 PANIC: Attempting to bring system down
>>16:06:23 semctl: errno = 22
>>
>>16:06:23 semctl: errno = 22>>
>>The Informix Version is 7.31 UC4 and the HP-UX Patches are current.
>>
>>Can anyone help us?
>>
>>Thanks
>>
>>Glenn
>>
>>
>>
>>
>
>
Known bug:-
Product Defect #70506 IF SHMMAX IN THE KERNEL IS LESS THAN RESIDENT
PORTION OF SHARED MEMORY,DSA DSA WILL NOT COME UP WITH KAIOON = 1,
ASYNC_ADDSEG FAILED, ERRNO = 14
This is similar to
Defect 104595 (Note only applies to version 8.x engines)
KAIO ON HP ASSUMES THAT EACH ONLINE SEGMENT WILL ONLY BE COMPOSED OF
ONE OS SEGMENT. RESULTS IN HPKAIOADDSEG: ASYNC_ADDSEG FAILED, ERRNO =
14
*** In both cases you need to increase the SHMMAX kernel parameter!!
--------------------------------------------------------------
Also check
Defect 110290
KAIO ON HP FAILS WITH THE FOLLOWING ERROR HPKAIOADDSEG: ASYNC_ADDSEG
FAILED, ERRNO = 12, ASSERT FAILED: KAIOTHREAD() ERROR
"On HP-UX 10.20 KAIO is failing when trying to initialize an
instance with a shared (Resident + Virtual) SHM SEG of size
93224960 , eventhough SHMMAX is set to 134217728. The same
configuration works just fine in 7.24.UC7, also with a smaller
shared memory segment KAIO works fine (i.e. SHM 82984960)
This is similar to what was reported in BUG 104595 but in
this case we have a single shared memory segment and the
SHMMAX is set to a value greater in size than the size of
the shared memory segment the engine allocated."
This is fixed in 7.31.UC6 of the engine!
*** Move to version 7.31.UC6 ASAP ***
-----------------------------
--
David Williams