27001 error
Posted in 2000
Like many folk, I too had read the manual and knew about poll threads and
blah blah (all suggestions greatly received nonetheless)!
However, it was noticed by one or two that our 27001 error was happening
with very few sessions and rightly pointed to a possible Unix resource
problem.
Turns out that the Informix 7.31 installation in question was fine BUT at
some point in time someone had probably executed chown informix * in the
$INFORMIXDIR/bin dir! Thus, certain processes and oninit especially did not
have root permissions on execution, (i.e use of SUID SGID but wrong
ownership: i.e ownership on file given to informix instead of root)
IDSfiles file was good for what the file permissions and ownership should be
exactly. So, changing the proper files back to root owner has resolved our
27001 problem with some 1000 sessions running successfully as a test.
Ta for the help, I'm off to see if I can get some petrol for my wee buggy;
the UK has come to something of a standstill!
W.