Q+E and Informix
Posted in 1999
Topics: General Discussion
Hi there, When I try to connect to any database in Informix v7.3 via Q+E v5.05, I get the following error: 'cannot open file sql.iem'. Does anyone know the cause of this error? Thanks, Michael O'Sullivan.
Michael O'Sullivan wrote: > Hi there, > > When I try to connect to any database in Informix v7.3 via Q+E v5.05, > I get the following error: 'cannot open file sql.iem'. > > Does anyone know the cause of this error? > > Thanks, > Michael O'Sullivan. sql.iem is a message file. In ancient releases it has been in $INFORMIXDIR/msg, in newr releases it is in $INFORMIXDIR/msg/en_us/0333. I think you should check language dependent variables such as DBLANG, CLIENT_LOCALE, ... And INFORMIXDIR of course. Regards -- Helmut Leininger Bull AG / Vienna Open Systems Support Email: h.leininger@bull.at helmut.leininger@bull.net This opinion is mine and not necessarily that of my employer. No guarantees whatsoever.
Helmut Leininger wrote: > > Michael O'Sullivan wrote: > > > Hi there, > > > > When I try to connect to any database in Informix v7.3 via Q+E v5.05, > > I get the following error: 'cannot open file sql.iem'. > > > > Does anyone know the cause of this error? > > > > Thanks, > > Michael O'Sullivan. > > sql.iem is a message file. In ancient releases it has been in > $INFORMIXDIR/msg, in newr releases it is in $INFORMIXDIR/msg/en_us/0333. > > I think you should check language dependent variables such as DBLANG, > CLIENT_LOCALE, ... And INFORMIXDIR of course. If that is the problem you can make softlinks to the message files in $INFORMIXDIR/msg itself from the subdir to support such older applications. This sometimes works. Art S. Kagel