Re: HELP: Lock rows in Informix SE
Posted in 1997
Florian Kerbl wrote: > > Hi there! > > We are running Informix SE V 5.0 with C-ISAM files on a UNIX Siemens > RM400 machine. > > We have the following problem if we try to update records with the > following command > > UPDATE tablename > SET field = value > WHERE condition > > The above only works if the affected table is not already open. If the > table is open we get the following error messages: > > - 263: could not lock row for UPDATE > - 107: C-ISAM error: row locked > > The same happens if we try to insert records except that instead of error > message 263, we get the error message 271 ("new record can not be > inserted into table"). > Is it possible that some other program has issued a "LOCK TABLE IN {SHARE|EXCLUSIVE} MODE" This should not be done unless absolutely necessary. Could be that your unix system doesn't have enough lock entries set in the system parms. HTH, Matt Brickley