Need help ! cannot connect to IDS 7.3 on NT 4.0
Posted in 2003
Topics: Backup & Restore, Storage & Space Management, Error Codes & Troubleshooting, Logging & Checkpoints, Networking & sqlhosts Configuration, Versions, Editions & End-of-Life
Hello,
My client has problem with their IDS, version 7.3 TC7 on NT 4.0 SP5. When we
execute IECC, it failed to connect with IDS, error -27004.
- Starting the service with ONINIT -v , all messages showed no error
- Execute ONCHECK -cc, message "shared memory is not initialized for server
..."
When we searched in the log file, we have found error :
Thu Sep 07 09:58:04 2000
09:58:04 DR: DRAUTO is 0 (Off)
09:58:10 Informix Dynamic Server Version 7.30.TC7 Software Serial Number XXXXX
09:58:10 Cannot Open Primary Chunk 'D:\\\\IFMXDATA\\\\ol_brm4\\\\rootdbs_dat.000',
errno = 2
09:58:10 Informix Dynamic Server Stopped.
09:58:17 mt_shm_remove: WARNING: may not have removed all/correct segments
==================================================
Tue Nov 07 14:48:12 2000
14:48:12 DR: DRAUTO is 0 (Off)
14:48:18 listener-thread: err = -27004: oserr = 0: errstr = : Illegal sqlhosts
file option/parameter.
14:48:18 Attempting to bring listener thread down
14:48:18 PANIC: Attempting to bring system down
==================================================
Thu Dec 27 15:43:02 2001
15:43:02 DR: DRAUTO is 0 (Off)
15:43:03 Informix Dynamic Server Version 7.30.TC7 Software Serial Number XXXXXX
15:43:04 WARNING! Physical Log size 0 is too small.
Physical Log overflows may occur during peak activity.
Recommended minimum Physical Log size is 20 times maximum
concurrent user threads.
15:43:04 WARNING! Logical log layout may cause Dynamic Server to get into
a locked state. Recommended smallest logical log size
is 2 times maximum concurrent user threads.
15:43:05 I/O bad request chunk 4095, pagenum 1048575, pagecnt 1
15:43:05 Assert Failed: No Exception Handler
15:43:05 Informix Dynamic Server Version 7.30.TC7
15:43:05 Who: Session(5, informix@brm4.caltex.co.th, 166, 0)
Thread(13, ontape, 0, 1)
Exception at Addr: 0x58a6a6, TOS: 0xc4e3ac4, FP:0xc4e3b24, Exc: c0000005
15:43:05 Results: Exception Caught. Type: MT_EX_OS, Context: mem
15:43:05 Action: Please notify Informix Technical Support.
15:43:20 See Also: af.ddf18, shmem.ddf18.0
15:43:21 , line -1, thread 13, proc id 113, No Exception Handler.
15:43:21 PANIC: Attempting to bring system down
==================================================
Wed Mar 20 10:12:43 2002
10:12:43 DR: DRAUTO is 0 (Off)
10:12:43 Informix Dynamic Server Version 7.30.TC7 Software Serial Number XXXXXX
10:12:44 Informix Dynamic Server Initialized -- Shared Memory Initialized.
10:12:44 Physical Recovery Started.
10:12:44 Physical Recovery Complete: 0 Pages Restored.
10:12:44 Logical Recovery Started.
10:12:47 Logical Recovery Complete.
0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
10:12:47 Dataskip is now OFF for all dbspaces
10:12:47 Init operation complete - Mode Online
10:12:47 On-Line Mode
10:12:58 Checkpoint Completed: duration was 0 seconds.
10:12:59 Assert Failed: No Exception Handler
10:12:59 Informix Dynamic Server Version 7.30.TC7
10:12:59 Who: Session(14, informix@, 0, 0)
Thread(9, soctcplst, 0, 1)
Exception at Addr: 0x776a1fe0, TOS: 0xc37b3dc, FP:0xc37b3f8, Exc: c0000005
10:12:59 Results: Exception Caught. Type: MT_EX_OS, Context: mem
10:12:59 Action: Please notify Informix Technical Support.
10:13:13 See Also: af.9fe3b, shmem.9fe3b.0
10:13:14 , line -1, thread 9, proc id 307, No Exception Handler.
10:13:14 PANIC: Attempting to bring system down
The system is downed for year, but our client want the data within it for
reference, the system is developed and implemented by the other company and
now it does not have anyone who know about the system.
If anyone can give suggestions, I will be highly appreciate.
Thanks,
Surajit
> SURAJIT said > Thu Sep 07 09:58:04 2000 > > 09:58:04 DR: DRAUTO is 0 (Off) > 09:58:10 Informix Dynamic Server Version 7.30.TC7 Software Serial Number XXXXX > 09:58:10 Cannot Open Primary Chunk 'D:\\\\IFMXDATA\\\\ol_brm4\\\\rootdbs_dat.000', errno = 2 > 09:58:10 Informix Dynamic Server Stopped. > 09:58:17 mt_shm_remove: WARNING: may not have removed all/correct segments > ================================================== > For a start two and a half years ago the chunk at D:\\\\IFMXDATA\\\\ol_brm4\\\\rootdbs_dat.000 could not be opened. Is it still there ? Has the system run since then ? If it is not there and you cannot restore it, wave bye bye to the data. Colin Bull c.bull@VideoNetworks.com