Re: Problem with 7.31 UC2 on Solaris 8
Posted in 2004
I experienced the same problem on Solaris 9 with IDS 7.31.UC2, upgrading to
7.31.FD7 solved the problem with no other changes...
Ben
----- Original Message -----
From: "Murray Wood (IList)" <ifxmaillist@quanta.co.nz>
To: <informix-list@iiug.org>
Sent: Tuesday, November 09, 2004 7:33 PM
Subject: RE: Problem with 7.31 UC2 on Solaris 8
> John
>
> 7.31.UC2 _may_ have been earlier than Solaris 8 so may not know about the
tcpip changes in Solaris 8 - to resolve this get the latest version of IDS.
You need the latest SUN patches on Solaris 8 (dont recall which one
specifically). I think you also need to enable IPV6.
>
> MW
>
> > -----Original Message-----
> > From: owner-informix-list@iiug.org
> > [mailto:owner-informix-list@iiug.org]On Behalf Of Spurgeon, John P
> > Sent: Wednesday, 10 November 2004 12:46 p.m.
> > To: informix-list@iiug.org
> > Subject: RE: Problem with 7.31 UC2 on Solaris 8
> >
> >
> > Hi Art,
> >
> > I tried your suggestion, and it didn't work. However, I was able to work
> > around the problem (sort of) by changing the sqlhosts entry for
> > "hostname" from:
> >
> > hostname ontlitcp hostname sqlexec> >
> > to:
> >
> > hostname onipcshm hostname shmem> >
> > and adding an entry in /etc/services for "shmem".
> >
> > This allows me to initialize the instance, use dbaccess (with
> > DBSERVERNAME="hostname"), etc. However, I can't revert back and make any
> > connections using ontlitcp. Whenever I try, I get the same type of error
> > message:
> >
> > 25572: Network driver cannot bind a name to the port.> >
> > I've tried using a different port number for sqlexec with no luck. I
> > don't think that's the problem. It seems like something related to the
> > tli/tcp protocol/interface has changed between Solaris 7 and Solaris 8
> > and beyond.
> >
> > If we were only running applications on the local server, maybe we could
> > live with that (or maybe not?), but I'm afraid this is going to be a
> > problem, since we need the ability to make remote database connections
> > for things like HDR.
> >
> > Any thoughts? I wonder if Sun could tell us what changed between Solaris
> > 7 and 8 and provide some sort of work-around...
> >
> > Thanks,
> > John
> >
> > -----Original Message-----
> > From: owner-informix-list@iiug.org [mailto:owner-informix-list@iiug.org]
> > On Behalf Of Art S. Kagel
> > Sent: Monday, November 08, 2004 2:48 PM
> > To: informix-list@iiug.org
> > Subject: Re: Problem with 7.31 UC2 on Solaris 8
> >
> > On Mon, 08 Nov 2004 15:21:30 -0500, Spurgeon, John P wrote:
> >
> > You can try running the buildsmi script (IB it's in $INFORMIXDIR/etc)
> > manually. That solved the problem in early IDS versions that
> > occassionally
> > had the same problem. If it does not work, then you have to upgrade to
> > 7.31
> > UD5 or whatever the latest is.
> >
> > Art S. Kagel
> >
> > > Hi,
> > >
> > > Our group uses IDS 7.31 UC2 on Solaris 7 (x86). We recently tried to
> > install
> > > the same version of IDS on Solaris 8 (x86). Things seemed to be
> > working OK
> > > until we tried to initialize the engine and the sysmaster database
> > failed to
> > > build. The issue is documented in the release notes for 7.31 UD1:
> > >
> > > 124759 ON SOLARIS 8, SERVER FAILS TO BUILD SYSMASTER BECAUSE
> > BUILDSMI
> > > CONNECT TO DATABASE FAILS WITH ERROR 25572 WITH "EXEC FORMAT ERROR"
> > USING
> > > TLITCP.
> > >
> > > Is there any way to work around the problem and use 7.31 UC2 on
> > Solaris 8,
> > > or have we reached a point where we have no choice but to upgrade IDS
> > if we
> > > want to run Solaris 8?
> > >
> > > Thanks,
> > > John
> > >
> > > sending to informix-list
> >
> > sending to informix-list
>
> sending to informix-list
sending to informix-list