problems to start an IDS 7.2-database under SCO
Posted in 2006
Topics: High Availability & Replication, Storage & Space Management, Error Codes & Troubleshooting, Versions, Editions & End-of-Life
We have a problem with a customer-system. The system didn't start and the
customer have no actual recovery. This message is coming up:
12:35:19 Event alarms enabled. ALARMPROG = '/usr/informix/etc/alarm.sh'
12:35:23 DR: DRAUTO is 0 (Off)
12:35:25 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
12:35:26 Physical Recovery Started.
12:35:27 Physical Recovery Complete: 0 Pages Restored.
12:35:27 Logical Recovery Started.
12:35:27 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
12:35:27 Who: Session(10, root@volz, 0, 319139560)
Thread(40, xchg_1.7, 1303d424, 1)
12:35:27 Results: Cannot use TBLSpace page for TBLSpace 2097157
12:35:27 Action: Run 'oncheck -pt 2097157'
12:35:27 See Also: /tmp/af.28f6ef
12:35:27 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
12:35:27 Who: Session(10, root@volz, 0, 319138976)
Thread(39, xchg_1.6, 1303cff0, 1)
12:35:27 Results: Cannot use TBLSpace page for TBLSpace 2097156
12:35:27 Action: Run 'oncheck -pt 2097156'
12:35:27 See Also: /tmp/af.27f6ef
12:35:27 Rollforward of log record failed. iserrno = 101
12:35:27 Log Record: log = 230, pos = 7c5038, type = 91[PTCOLUMN], trans =13
12:35:27 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
12:35:27 Who: Session(10, root@volz, 0, 319140728)
Thread(42, xchg_1.9, 1303dc8c, 1)
12:35:27 Results: Cannot use TBLSpace page for TBLSpace 2097159
12:35:27 Action: Run 'oncheck -pt 2097159'
12:35:27 See Also: /tmp/af.2af6ef
12:35:27 Rollforward of log record failed. iserrno = 101
12:35:27 Log Record: log = 230, pos = 7c5260, type = 91[PTCOLUMN], trans =13
12:35:27 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
12:35:27 Who: Session(10, root@volz, 0, 319141020)
Thread(33, xchg_1.0, 1303b6b8, 1)
12:35:27 Results: Cannot use TBLSpace page for TBLSpace 2097160
12:35:27 Action: Run 'oncheck -pt 2097160'
12:35:27 See Also: /tmp/af.21f6ef
12:35:27 Rollforward of log record failed. iserrno = 101
12:35:27 Log Record: log = 230, pos = 7c52bc, type = 91[PTCOLUMN], trans =13
12:35:27 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
12:35:27 Who: Session(10, root@volz, 0, 319141896)
Thread(35, xchg_1.2, 1303bf20, 1)
12:35:27 Results: Cannot use TBLSpace page for TBLSpace 2097162
12:35:27 Action: Run 'oncheck -pt 2097162'
12:35:27 See Also: /tmp/af.23f6ef
12:35:27 Rollforward of log record failed. iserrno = 101
12:35:27 Log Record: log = 230, pos = 7c53d0, type = 91[PTCOLUMN], trans =13
12:35:28 Assert Failed: WARNING! Chunk 2 is being taken OFFLINE.
12:35:28 Who: Session(10, root@volz, 0, 319138684)
Thread(39, xchg_1.6, 1303cff0, 1)
12:35:28 Results: OnLine must abort
12:35:28 Action: Reinitialize shared memory
12:35:28 See Also: /tmp/af.27f6ef
12:35:28 rsmirror.c, line 1656, thread 39, proc id 701, INFORMIX-OnLineMust ABORT
Critical media failure..
12:35:28 PANIC: Attempting to bring system down
Any idea welcome
Georg Walk
Georg Walk said: > Any idea welcome Run, don't Walk, for the nearest exit. :o) Seriously, if they don't have backups and they have page corruption, you are "faced with enormous challenges". -- Bye now, Obnoxio "... no bill is required as no value was provided." -- Christine Normile -- This message has been scanned for viruses and dangerous content by OpenProtect(http://www.openprotect.com), and is believed to be clean.
Restore form archive; in case you haven't got one, phone TS
they may be able to hack your system....
Superboer
Georg Walk schreef:
> We have a problem with a customer-system. The system didn't start and the
> customer have no actual recovery. This message is coming up:
> 12:35:19 Event alarms enabled. ALARMPROG = '/usr/informix/etc/alarm.sh'
> 12:35:23 DR: DRAUTO is 0 (Off)
> 12:35:25 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
> 12:35:26 Physical Recovery Started.
> 12:35:27 Physical Recovery Complete: 0 Pages Restored.
> 12:35:27 Logical Recovery Started.
> 12:35:27 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
> 12:35:27 Who: Session(10, root@volz, 0, 319139560)
> Thread(40, xchg_1.7, 1303d424, 1)
> 12:35:27 Results: Cannot use TBLSpace page for TBLSpace 2097157
> 12:35:27 Action: Run 'oncheck -pt 2097157'
> 12:35:27 See Also: /tmp/af.28f6ef
> 12:35:27 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
> 12:35:27 Who: Session(10, root@volz, 0, 319138976)
> Thread(39, xchg_1.6, 1303cff0, 1)
> 12:35:27 Results: Cannot use TBLSpace page for TBLSpace 2097156
> 12:35:27 Action: Run 'oncheck -pt 2097156'
> 12:35:27 See Also: /tmp/af.27f6ef
> 12:35:27 Rollforward of log record failed. iserrno = 101
> 12:35:27 Log Record: log = 230, pos = 7c5038, type = 91[PTCOLUMN], trans => 13
> 12:35:27 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
> 12:35:27 Who: Session(10, root@volz, 0, 319140728)
> Thread(42, xchg_1.9, 1303dc8c, 1)
> 12:35:27 Results: Cannot use TBLSpace page for TBLSpace 2097159
> 12:35:27 Action: Run 'oncheck -pt 2097159'
> 12:35:27 See Also: /tmp/af.2af6ef
> 12:35:27 Rollforward of log record failed. iserrno = 101
> 12:35:27 Log Record: log = 230, pos = 7c5260, type = 91[PTCOLUMN], trans => 13
> 12:35:27 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
> 12:35:27 Who: Session(10, root@volz, 0, 319141020)
> Thread(33, xchg_1.0, 1303b6b8, 1)
> 12:35:27 Results: Cannot use TBLSpace page for TBLSpace 2097160
> 12:35:27 Action: Run 'oncheck -pt 2097160'
> 12:35:27 See Also: /tmp/af.21f6ef
> 12:35:27 Rollforward of log record failed. iserrno = 101
> 12:35:27 Log Record: log = 230, pos = 7c52bc, type = 91[PTCOLUMN], trans => 13
> 12:35:27 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
> 12:35:27 Who: Session(10, root@volz, 0, 319141896)
> Thread(35, xchg_1.2, 1303bf20, 1)
> 12:35:27 Results: Cannot use TBLSpace page for TBLSpace 2097162
> 12:35:27 Action: Run 'oncheck -pt 2097162'
> 12:35:27 See Also: /tmp/af.23f6ef
> 12:35:27 Rollforward of log record failed. iserrno = 101
> 12:35:27 Log Record: log = 230, pos = 7c53d0, type = 91[PTCOLUMN], trans => 13
> 12:35:28 Assert Failed: WARNING! Chunk 2 is being taken OFFLINE.
> 12:35:28 Who: Session(10, root@volz, 0, 319138684)
> Thread(39, xchg_1.6, 1303cff0, 1)
> 12:35:28 Results: OnLine must abort
> 12:35:28 Action: Reinitialize shared memory
> 12:35:28 See Also: /tmp/af.27f6ef
> 12:35:28 rsmirror.c, line 1656, thread 39, proc id 701, INFORMIX-OnLine> Must ABORT
> Critical media failure..
> 12:35:28 PANIC: Attempting to bring system down>
> Any idea welcome
> Georg Walk
although if you really have Informix 7.2 I suspect support will infomr you that product has not been supported for a very very long time