Make error -369 DBD-Informix
Posted in 1999
Topics: Installation, Setup & Upgrades, Connectivity: ESQL/C, 4GL & Embedded SQL
We are receiving the error "-369 Invalid serial number - consult installation instructions" when running "perl Makefile.PL" on an Intel Solaris 7 platform for DBD-Informix 0.60. The order of installation of the Informix products was SQL, ESQL, IDS, and then IConnect. We called Informix Tech Support to confirm the order of installation. We were concerned especially about ESQL/C and IConnect. The version of ESQL/C is 7.23 UC1, ICONNECT version is 2.01 UC1 and IDS is version 7.30 UC2. We used the same serial number for all products based on the serial number supplied by Intraware at their download site. ( Last week DBD-INFORMIX compiled when our installation order was IDS, ICONNECT, then ESQL/C, then ISQL, however when we shutdown and restarted the Online db engine, we ran into the problem of " message file not found , check INFORMIXDIR and DBLANG" which prompted our call to Informix Tech Support). We appreciate in advance any assistance from the Newsgroup :-)) Thank you!
David McNight wrote: > > We are receiving the error "-369 Invalid serial number - consult > installation instructions" when running "perl Makefile.PL" on an Intel > Solaris 7 platform for DBD-Informix 0.60. The order of installation of > the Informix products was SQL, ESQL, IDS, and then IConnect. We called > Informix Tech Support to confirm the order of installation. We were > concerned especially about ESQL/C and IConnect. The version of ESQL/C is > 7.23 UC1, ICONNECT version is 2.01 UC1 and IDS is version 7.30 UC2. We > used the same serial number for all products based on the serial number > supplied by Intraware at their download site. > > ( Last week DBD-INFORMIX compiled when our installation order was IDS, > ICONNECT, then ESQL/C, then ISQL, however when we shutdown and > restarted the Online db engine, we ran into the problem of " message > file not found , check INFORMIXDIR and DBLANG" which prompted our call > to Informix Tech Support). Most probably, you copied some product off the medium (CD) and didn't run the relevant install program. Since it is DBD::Informix which is uncovering the problem, the most likely candidate is the ESQL/C product. You should be able to compile and run the following code: int main(int argc, char **argv) { $ WHENEVER ERROR STOP; $ DATABASE stores7; puts("OK"); return(0); } If this cannot be compiled because of licence problems, then ESQL/C needs to be licenced; run ./installesql as root in $INFORMIXDIR. If it can be compiled but fails at runtime, the problem is more likely to be I-Connect, but it could be either. Run the corresponding install scripts again. If it runs but fails with 'database not found' or produces OK, then your ESQL/C is OK. It is then far from clear why DBD::Informix is failing. Further analysis would require platform and product version numbers in excruciating detail, reported to the correct forum (which is not actually comp.databases.informix, as you'd know if you read the README file). -- Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net) Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN #include <disclaimer.h>
We re-installed and everything is working fine with Informix IDS on Solaris.:-)) Thank you very much for your expert information! One new thing we are running into is an error -461 when trying to run a CGI script that stores rows into a single table. We are running apache on Solaris along with IDS server. We created a html form and access it through Netscape. One of guys took our perl script and tried to make it work with CGI. We can run the basic script using perl and we can store rows successfully running as user informix into the stores7 database. However when move the basic logic into the CGI script, we receive the message "DBI-connect failed SQL -461 <<Failed to locate SQL error message >> at /opt/cgi-bin/dormform.cgi line 11. (We cannot connect to the Informix database using Apache and Netscape?) We placed the Informix/DBD Informix required environment variables into the httpd.conf configuration file for Apache, but we still receive the -461 error. Any ideas for correction are greatly appreciated :-)) Jonathan Leffler wrote: > David McNight wrote: > > > > We are receiving the error "-369 Invalid serial number - consult > > installation instructions" when running "perl Makefile.PL" on an Intel > > Solaris 7 platform for DBD-Informix 0.60. The order of installation of > > the Informix products was SQL, ESQL, IDS, and then IConnect. We called > > Informix Tech Support to confirm the order of installation. We were > > concerned especially about ESQL/C and IConnect. The version of ESQL/C is > > 7.23 UC1, ICONNECT version is 2.01 UC1 and IDS is version 7.30 UC2. We > > used the same serial number for all products based on the serial number > > supplied by Intraware at their download site. > > > > ( Last week DBD-INFORMIX compiled when our installation order was IDS, > > ICONNECT, then ESQL/C, then ISQL, however when we shutdown and > > restarted the Online db engine, we ran into the problem of " message > > file not found , check INFORMIXDIR and DBLANG" which prompted our call > > to Informix Tech Support). > > Most probably, you copied some product off the medium (CD) and didn't > run the relevant install program. Since it is DBD::Informix which is > uncovering the problem, the most likely candidate is the ESQL/C product. > > You should be able to compile and run the following code: > > int main(int argc, char **argv) > { > $ WHENEVER ERROR STOP; > $ DATABASE stores7; > puts("OK"); > return(0); > } > > If this cannot be compiled because of licence problems, then ESQL/C > needs to be licenced; run ./installesql as root in $INFORMIXDIR. If > it can be compiled but fails at runtime, the problem is more likely > to be I-Connect, but it could be either. Run the corresponding install > scripts again. If it runs but fails with 'database not found' or > produces OK, then your ESQL/C is OK. It is then far from clear why > DBD::Informix is failing. > > Further analysis would require platform and product version numbers > in excruciating detail, reported to the correct forum (which is not > actually comp.databases.informix, as you'd know if you read the > README file). > > -- > Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net) > Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN > #include <disclaimer.h>
David McNight wrote: > > We re-installed and everything is working fine with Informix IDS on > Solaris.:-)) Thank you very much for your expert information! > One new thing we are running into is an error -461 when trying to > run a CGI script that stores rows into a single table. Error -461 is all about opening files and blobs, at least according to the finderr program. However, it also crops up when you have the incorrect version of some error message file in the $INFORMIXDIR/msg directory. It is usually something to do with SET EXPLAIN, rather than simply connecting to the database, but this doesn't seem to be your problem. However, I'd investigate what happens if you install IDS and CSDK in the other order from the one you used -- preferably by using an alternative directory rather than by actually reinstalling in your main (more or less) working INFORMIXDIR. > We are running apache on Solaris along with IDS server. We created > a html form and access it through Netscape. One of guys took our > perl script and tried to make it work with CGI. We can run the > basic script using perl and we can store rows successfully running > as user informix into the stores7 database. You should not need to be user informix for it to work. If you do, you need to check database permissions, and possibly the basic product permissions (the permissions under $INFORMIXDIR). You should aim to do nothing which is not strictly administration of the IDS system as user informix - all DBA work for a database should be done as some other user. > However when move the basic logic into the CGI script, we receive > the message "DBI-connect failed SQL -461 <<Failed to locate SQL > error message >> at /opt/cgi-bin/dormform.cgi line 11. (We cannot > connect to the Informix database using Apache and Netscape?) Maybe. Are you specifying a username and password when you connect? Which user is the web server running as? Can that user connect to the database? > We placed the Informix/DBD Informix required environment variables > into the httpd.conf configuration file for Apache, but we still > receive the -461 error. I suspect that your Informix installation is not perfect yet. I also suspect that you have permissions problems on the database because your web server is running as some unprivileged user (nobody? or webusr? or something) and you have not given that user permission to access the database. Installation order is depressingly tricky. -- Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net) Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN #include <disclaimer.h>