WL -244 Could not do a physical-order read to
Posted in 2013
Topics: Performance & Tuning, Error Codes & Troubleshooting, Connectivity: ODBC / JDBC / .NET, Server Administration, Transactions, Locking & Isolation, Versions, Editions & End-of-Life
Hi Gurus,
I would like to ask your assistance on isolating the problem encountered
below. The application team is trying to isolate what caused the problem -244
in Weblogic Apps Server side. I have already verified the indexes and also
done update statistics of the tables concerned.
WARN : 05.20.2013:2036 (49.166) [[ACTIVE] ExecuteThread: '10' for queue:
'weblogic.kernel.Default (self-tuning)']
org.hibernate.util.JDBCExceptionReporter: SQL Error: -244, SQLState: HY000
ERROR : 05.20.2013:2036 (49.166) [[ACTIVE] ExecuteThread: '10' for queue:
'weblogic.kernel.Default (self-tuning)']
org.hibernate.util.JDBCExceptionReporter: [FMWGEN][Informix JDBC
Driver][Informix]Could not do a physical-order read to fetch next row.
INFO : 05.20.2013:2036 (49.166) [[ACTIVE] ExecuteThread: '10' for queue:
'weblogic.kernel.Default (self-tuning)']
org.hibernate.event.def.DefaultLoadEventListener: Error performing load command
org.hibernate.exception.GenericJDBCException: could not load an entity:
Upon checking, -244 is due to :
=>finderr 244
-244 Could not do a physical-order read to fetch next row.
The database server cannot read the disk page that contains a row of a
table. Check the accompanying ISAM error code for more information. A
hardware problem might exist, or the table or index file might have
been corrupted. Unless the ISAM error code or an operating-system
message points to another cause, run the bcheck or secheck utility to
verify file integrity.
I have asked the user to "set isolation to wait N", where N is a number (in
seconds). Is there any other way to resolve this issue? I really appreciate
your help on this. May I also know the default isolation level for IDS?
is it:
set isolation to dirty read?
set isolation to wait N?
Can isolation level be set via onconfig? Does the instance needs restart?
I'm using IDS 9.4 in SunOS 5.7.
I'm sure that itis probably set already=2C but you could also check if the =
table has lock mode row or lock mode page
--- Original Message ---
From: "JACK PAPA" <informix2009@gmail.com>
Sent: May 21=2C 2013 12:09 PM
To: ids@iiug.org
Subject: WL -244 Could not do a physical-order read to [30306]
Hi Gurus=2C
I would like to ask your assistance on isolating the problem encountered
below. The application team is trying to isolate what caused the problem -2=
44
in Weblogic Apps Server side. I have already verified the indexes and also
done update statistics of the tables concerned.
WARN : 05.20.2013:2036 (49.166) [[ACTIVE] ExecuteThread: '10' for queue:
'weblogic.kernel.Default (self-tuning)']
org.hibernate.util.JDBCExceptionReporter: SQL Error: -244=2C SQLState: HY00=
0
ERROR : 05.20.2013:2036 (49.166) [[ACTIVE] ExecuteThread: '10' for queue:
'weblogic.kernel.Default (self-tuning)']
org.hibernate.util.JDBCExceptionReporter: [FMWGEN][Informix JDBC
Driver][Informix]Could not do a physical-order read to fetch next row.
INFO : 05.20.2013:2036 (49.166) [[ACTIVE] ExecuteThread: '10' for queue:
'weblogic.kernel.Default (self-tuning)']
org.hibernate.event.def.DefaultLoadEventListener: Error performing load
command
org.hibernate.exception.GenericJDBCException: could not load an entity:
Upon checking=2C -244 is due to :
=3D>finderr 244
-244 Could not do a physical-order read to fetch next row.
The database server cannot read the disk page that contains a row of a
table. Check the accompanying ISAM error code for more information. A
hardware problem might exist=2C or the table or index file might have
been corrupted. Unless the ISAM error code or an operating-system
message points to another cause=2C run the bcheck or secheck utility to
verify file integrity.
I have asked the user to "set isolation to wait N"=2C where N is a number (=
in
seconds). Is there any other way to resolve this issue? I really appreciate
your help on this. May I also know the default isolation level for IDS?
is it:
set isolation to dirty read?
set isolation to wait N?
Can isolation level be set via onconfig? Does the instance needs restart?
I'm using IDS 9.4 in SunOS 5.7.
***************************************************************************=
****
Forum Note: Use "Reply" to post a response in the discussion forum.