ODBC 42000 Error
Posted in 2014
Topics: Connectivity: ODBC / JDBC / .NET, Third-Party Tools & Monitoring
I am trying to connect to an IDS 11.70.FC4 database on SLES 11 via ODBC from a Windows 2012 R2 server. Iâm using the 64-bit 4.10 SDK, but Iâve also tried 3.50 and 3.70. I can connect to the database and execute queries fine. However, I have one vendor provided synchronization process that returns the following error: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Data.Odbc.OdbcException: ERROR [42000][Informix][Informix ODBC Driver][Informix]A syntax error has occurred. at System.Data.Odbc.OdbcConnection.HandleError(OdbcHandlehrHandle, RetCode retched) at System.DataOdbc.OdbcCommand.ExecuteReaderObject(CommandBehaviour behavior, String method, Boolean needReader, Object[] methodArguments, SQL_API odbcApiMethod) at ⦠The error goes on for a while. Unfortunately, since it is a Windows dialog box, I cannot copy and paste the verbiage. I have included a screenshot of the error, but Iâm not sure if attachments are supported on this list. I have attempted to trace the user via OAT and I can see the previous SQL statements executing successfully, but this one does not seem to make it to the database. Therefore, my assumption is that it is syntax error on the vendors system that isnât making it past the ODBC layer on the Windows server. We are beginning implementation with this particular vendor and they do not seem to know what is causing the error (they are point to a data issue on the database, but I am not seeing the query during a trace). Does anyone know what may cause this type of ODBC error or what I can do to troubleshoot it? [cid:181B2885-F9AC-46EE-A734-9D8E9829F665@midwestern.edu]
Hi Rubinstein, Try checking the space on the server -4200 is Write error -- out of disk space. The error message is without minus sign though. Regards, Satyan Advisory Software Engineer R&D - IBM Information Management Division 11200 Lakeview, Lenexa, KS 66219 Tel: 913 599 8792 (T/L: 337-8792) From: "Rubinstein, James" <JRUBIN@midwestern.edu> To: ids@iiug.org Date: 12/11/2014 03:44 PM Subject: ODBC 42000 Error [34338] Sent by: ids-bounces@iiug.org I am trying to connect to an IDS 11.70.FC4 database on SLES 11 via ODBC from a Windows 2012 R2 server. I’m using the 64-bit 4.10 SDK, but I’ve also tried 3.50 and 3.70. I can connect to the database and execute queries fine. However, I have one vendor provided synchronization process that returns the following error: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Data.Odbc.OdbcException: ERROR [42000][Informix][Informix ODBC Driver][Informix]A syntax error has occurred. at System.Data.Odbc.OdbcConnection.HandleError(OdbcHandlehrHandle, RetCode retched) at System.DataOdbc.OdbcCommand.ExecuteReaderObject (CommandBehaviour behavior, String method, Boolean needReader, Object[] methodArguments, SQL_API odbcApiMethod) at … The error goes on for a while. Unfortunately, since it is a Windows dialog box, I cannot copy and paste the verbiage. I have included a screenshot of the error, but I’m not sure if attachments are supported on this list. I have attempted to trace the user via OAT and I can see the previous SQL statements executing successfully, but this one does not seem to make it to the database. Therefore, my assumption is that it is syntax error on the vendors system that isn’t making it past the ODBC layer on the Windows server. We are beginning implementation with this particular vendor and they do not seem to know what is causing the error (they are point to a data issue on the database, but I am not seeing the query during a trace). Does anyone know what may cause this type of ODBC error or what I can do to troubleshoot it? [cid:181B2885-F9AC-46EE-A734-9D8E9829F665@midwestern.edu] ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
Hi Rubinstein, Try checking the space on the server -4200 is Write error -- out of disk space. The error message is without minus sign though Regards, Satyan Advisory Software Engineer R&D - IBM Information Management Division 11200 Lakeview, Lenexa, KS 66219 Tel: 913 599 8792 (T/L: 337-8792) ids-bounces@iiug.org wrote on 12/11/2014 03:44:04 PM: > From: "Rubinstein, James" <JRUBIN@midwestern.edu> > To: ids@iiug.org > Date: 12/11/2014 03:44 PM > Subject: ODBC 42000 Error [34338] > Sent by: ids-bounces@iiug.org > > I am trying to connect to an IDS 11.70.FC4 database on SLES 11 via > ODBC from a > Windows 2012 R2 server. I’m using the 64-bit 4.10 SDK, but I’ve > also tried > 3.50 and 3.70. I can connect to the database and execute queries fine. > However, I have one vendor provided synchronization process that returns the > following error: > > System.Web.Services.Protocols.SoapException: Server was unable to process > request. ---> System.Data.Odbc.OdbcException: ERROR [42000] > [Informix][Informix > ODBC Driver][Informix]A syntax error has occurred. at > System.Data.Odbc.OdbcConnection.HandleError(OdbcHandlehrHandle, RetCode > retched) at System.DataOdbc.OdbcCommand.ExecuteReaderObject (CommandBehaviour > behavior, String method, Boolean needReader, Object[] > methodArguments, SQL_API > odbcApiMethod) at … > > The error goes on for a while. Unfortunately, since it is a Windows dialog > box, I cannot copy and paste the verbiage. I have included a > screenshot of the > error, but I’m not sure if attachments are supported on this list. > > I have attempted to trace the user via OAT and I can see the previous SQL > statements executing successfully, but this one does not seem to make it to > the database. Therefore, my assumption is that it is syntax error on the > vendors system that isn’t making it past the ODBC layer on the Windows > server. > > We are beginning implementation with this particular vendor and they do not > seem to know what is causing the error (they are point to a data issue on the > database, but I am not seeing the query during a trace). > > Does anyone know what may cause this type of ODBC error or what I can do to > troubleshoot it? > > [cid:181B2885-F9AC-46EE-A734-9D8E9829F665@midwestern.edu] > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. >
On a hunch, I ran this through a base64 decoder and see the following: Try checking the space on the server -4200 is Write error -- out of disk space. The error message is without minus sign though. Regards, Satyan Advisory Software Engineer R&D - IBM Information Management Division Please note that the ODBC error is 42000, not 4200. I see that 4200 is: -4200 Write error -- out of disk space. The compiler failed to write some information to the output file because it ran out of disk space. My error is not 4200 (42-hundred) though. It is 42000 (42-thousand). Just to reiterate, the error is happening within the vendor application on a Windows server with the Informix 4.10 SDK installed and ODBC configured. My database server is IDS 11.70 on SLES. Most queries within the Windows application run fine and return data. User tracking on the Informix SLES server shows the queries. One particular query bombs out with the 42000 error. I never see the bad SQL with user tracing turned on, so Iâm guessing that it is never making it out of the Windows server to my Linux database server. > ---------- Original Message ---------- > From: Sathyanesh Krishnan > Sent: December 11, 2014 at 4:19:48 PM MST > To: ids@iiug.org > Subject: Re: ODBC 42000 Error [34340] > > > Hi Rubinstein, > > Try checking the space on the server > -4200 is Write error -- out of disk space. > The error message is without minus sign though > > Regards, > Satyan > > Advisory Software Engineer > R&D - IBM Information Management Division > 11200 Lakeview, Lenexa, KS 66219 > Tel: 913 599 8792 (T/L: 337-8792) > > > ids-bounces@iiug.org wrote on 12/11/2014 03:44:04 PM: > > > From: "Rubinstein, James" <JRUBIN@midwestern.edu> > > To: ids@iiug.org > > Date: 12/11/2014 03:44 PM > > Subject: ODBC 42000 Error [34338] > > Sent by: ids-bounces@iiug.org > > > > I am trying to connect to an IDS 11.70.FC4 database on SLES 11 via > > ODBC from a > > Windows 2012 R2 server. I’m using the 64-bit 4.10 SDK, but I’ve > > also tried > > 3.50 and 3.70. I can connect to the database and execute queries fine. > > However, I have one vendor provided synchronization process that returns > the > > following error: > > > > System.Web.Services.Protocols.SoapException: Server was unable to process > > > request. ---> System.Data.Odbc.OdbcException: ERROR [42000] > > [Informix][Informix > > ODBC Driver][Informix]A syntax error has occurred. at > > System.Data.Odbc.OdbcConnection.HandleError(OdbcHandlehrHandle, RetCode > > retched) at System.DataOdbc.OdbcCommand.ExecuteReaderObject > (CommandBehaviour > > behavior, String method, Boolean needReader, Object[] > > methodArguments, SQL_API > > odbcApiMethod) at … > > > > The error goes on for a while. Unfortunately, since it is a Windows > dialog > > box, I cannot copy and paste the verbiage. I have included a > > screenshot of the > > error, but I’m not sure if attachments are supported on this list. > > > > I have attempted to trace the user via OAT and I can see the previous SQL > > > statements executing successfully, but this one does not seem to make it > to > > the database. Therefore, my assumption is that it is syntax error on the > > vendors system that isn’t making it past the ODBC layer on the Windows > > server. > > > > We are beginning implementation with this particular vendor and they do > not > > seem to know what is causing the error (they are point to a data issue on > the > > database, but I am not seeing the query during a trace). > > > > Does anyone know what may cause this type of ODBC error or what I can do > to > > troubleshoot it? > > > > [cid:181B2885-F9AC-46EE-A734-9D8E9829F665@midwestern.edu] > > > > > > > ******************************************************************************* > > > Forum Note: Use "Reply" to post a response in the discussion forum. > > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. >