IDS does not start due to rollback error 126
Posted in 2011
Topics: Error Codes & Troubleshooting, Logging & Checkpoints, Platform-Specific Issues, Versions, Editions & End-of-Life
Platform Solaris 9, IDS 9.4UC6
Logical logs were full, during backup of logical logs, occured a rollback
error 126
Unable to start again.
Logfile indicates : use onlog to view and repair transaction mmanually.
Any information about how to do this ?
Restore is the last possibility as we loose about 6 hours of work.
Any help will be appreciated.
Thanks,
Jacques Lapeire
Extract logfile :
50410 12:58:30 Assert Failed: Rollback error 126
50411 12:58:30 IBM Informix Dynamic Server Version 9.40.UC6
50412 12:58:30 Who: Session(3230964, asserv@brintra01.chu-brugmann.be, 5488
1d5b1bd8)
50413 Thread(3237912, sqlexec, 1f7f1930, 3)
50414 File: rstrans.c Line: 2427
50415 12:58:30 Results: Log record (OLDRSAM:HUPDATE) in log 43979, offset
0xe31ac was not rolled back
50416 12:58:30 Action: Use 'onlog' to view the transaction and repair manually.
50417 12:58:30 stack trace for pid 1861 written to /var/tmp/af.6c008066
50418 12:58:30 See Also: /var/tmp/af.6c008066, shmem.6c008066.0,
gcore.6c008066.0.1861
Call IBM, open a down system case, they can log in and truncate the damaged
logical log so you can get back online. You may loose a few minutes of
transactions and one or more transactions that completed may now rollback,
but that's better than nothing.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
IIUG Board of Directors (art@iiug.org)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Advanced DataTools, the IIUG, nor any other
organization with which I am associated either explicitly, implicitly, or by
inference. Neither do those opinions reflect those of other individuals
affiliated with any entity with which I am affiliated nor those of the
entities themselves.
On Tue, Jan 18, 2011 at 8:31 AM, JACQUES LAPEIRE <
jacques.lapeire@ts.fujitsu.com> wrote:
> Platform Solaris 9, IDS 9.4UC6
>
> Logical logs were full, during backup of logical logs, occured a rollback
> error 126
>
> Unable to start again.
>
> Logfile indicates : use onlog to view and repair transaction mmanually.
>
> Any information about how to do this ?
>
> Restore is the last possibility as we loose about 6 hours of work.
>
> Any help will be appreciated.
>
> Thanks,
> Jacques Lapeire
>
> Extract logfile :
>
> 50410 12:58:30 Assert Failed: Rollback error 126
> 50411 12:58:30 IBM Informix Dynamic Server Version 9.40.UC6
> 50412 12:58:30 Who: Session(3230964, asserv@brintra01.chu-brugmann.be,
> 5488
> 1d5b1bd8)
>
> 50413 Thread(3237912, sqlexec, 1f7f1930, 3)
> 50414 File: rstrans.c Line: 2427
> 50415 12:58:30 Results: Log record (OLDRSAM:HUPDATE) in log 43979, offset
> 0xe31ac was not rolled back
> 50416 12:58:30 Action: Use 'onlog' to view the transaction and repair
> manually.
> 50417 12:58:30 stack trace for pid 1861 written to /var/tmp/af.6c008066
> 50418 12:58:30 See Also: /var/tmp/af.6c008066, shmem.6c008066.0,
> gcore.6c008066.0.1861
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--001636c5b45f18b572049a1f0af3