onbar backup fails with BSACreateObject error rega
Posted in 2011
Topics: Backup & Restore, Platform-Specific Issues, Versions, Editions & End-of-Life
IBM Informix Dynamic Server Version 11.70.FC1
HP-UX B.11.31 itanium64
HP Data Protector Software Version 6.11
onbar backup fails with following error.
# bar_act.log Error
2011-01-19 06:08:36 14252 14250 Begin backup of critical file
'/usr/informix/etc/ixbar.0'.
2011-01-19 06:09:12 14252 14250 XBSA Error: (BSACreateObject) A system
error occurred. Aborting XBSA session.
2011-01-19 06:09:12 14252 14250 /usr/informix/bin/onbar_d complete,
returning 0 (0x00)
Data Protector Log Error:
[Major] From: BSM@etapemanagement.pascoccc.local "vuxtech_daily_full"
Time: 1/19/11 5:56:07 AM
No resource of type "CF" available.
Client will be aborted.
[Major] From: OB2BAR@vuxttech.pascoccc.local "vuxtech" Time: 1/19/11
6:09:12 AM
Received ABORT request from RSM (ERR: Error starting
backup/restore (BMA cannot be started or similar).)
The Informix Dynamic Server Version 11.7 is not supported by the HP Data
Protector.
I contacted IBM Tech. His answer is as follows:
The document explains and gives a resolution for this most recent error
message you encountered:
https://www.ibm.com/support/docview.wss?uid=swg21454904
<https://www.ibm.com/support/docview.wss?uid=swg21454904>
To summarize you need to run onbar like this:
onbar -b -L 0 -w -cf no
Now I want to know how you change the backup command using Data
Protector, so it want backp critical files.
I don't know where the configuration file for onbar backup is ? Is it on
Infomix server or on Data Protector Cell server?
Thank you
Kanti Bakarania.
>>I don't know where the configuration file for onbar backup is ? Is it on
>>Infomix server or on Data Protector Cell server?
onbar configuration files are on your informix server in your $INFORMIXDIR
...
your error message tells you at least one of the files onbar considers
critical:
2011-01-19 06:08:36 14252 14250 Begin backup of critical file
'/usr/informix/etc/ixbar.0'.
from your error you know you need to backup your ixbar.0 file.
read the Informix backup & recover guide to understand what other files
onbar considers to be critical and get those on some form of system backup
to be stored with your onbar backups in the event you need to recover, you
will need the critical onbar files.
On Wed, Jan 19, 2011 at 12:29 PM, Bakarania, Kanti <
KBakarania@pascoclerk.com> wrote:
> IBM Informix Dynamic Server Version 11.70.FC1
>
> HP-UX B.11.31 itanium64
>
> HP Data Protector Software Version 6.11
>
> onbar backup fails with following error.
>
> # bar_act.log Error
>
> 2011-01-19 06:08:36 14252 14250 Begin backup of critical file
> '/usr/informix/etc/ixbar.0'.
>
> 2011-01-19 06:09:12 14252 14250 XBSA Error: (BSACreateObject) A system
> error occurred. Aborting XBSA session.
>
> 2011-01-19 06:09:12 14252 14250 /usr/informix/bin/onbar_d complete,
> returning 0 (0x00)
>
> Data Protector Log Error:
>
> [Major] From: BSM@etapemanagement.pascoccc.local "vuxtech_daily_full"
> Time: 1/19/11 5:56:07 AM
>
> No resource of type "CF" available.
>
> Client will be aborted.
>
> [Major] From: OB2BAR@vuxttech.pascoccc.local "vuxtech" Time: 1/19/11
> 6:09:12 AM
>
> Received ABORT request from RSM (ERR: Error starting
> backup/restore (BMA cannot be started or similar).)
>
> The Informix Dynamic Server Version 11.7 is not supported by the HP Data
> Protector.
>
> I contacted IBM Tech. His answer is as follows:
>
> The document explains and gives a resolution for this most recent error
> message you encountered:
>
> https://www.ibm.com/support/docview.wss?uid=swg21454904
> <https://www.ibm.com/support/docview.wss?uid=swg21454904>
>
> To summarize you need to run onbar like this:
>
> onbar -b -L 0 -w -cf no>
> Now I want to know how you change the backup command using Data
> Protector, so it want backp critical files.
>
> I don't know where the configuration file for onbar backup is ? Is it on
> Infomix server or on Data Protector Cell server?
>
> Thank you
>
> Kanti Bakarania.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--0016364edb0c2052c5049a3df19c