Occasional onbar log backup hangs
Posted in 2009
Topics: Backup & Restore, Logging & Checkpoints
Hi all
Every now and then (about twice a week) I have an issue whereby
a log backup using onbar -b -l to TSM seems to hang, or take a very
long time to complete. This means that subsequent log backups fail,
with the message about cannot start a log backup because another
one is already running. The 'fix' is to kill the hanging onbar
process, whereby another starts and all the stacked-up logs
back up OK. I'm going to set BAR_DEBUG today but I was just
wondering if anyone's seen a similar issue?
Thanks.
J.
JPM wrote:
bar_act.log and//or bar_debug.log might give you a hint what's happening.
Also, try to catch a stack of the ontape process when the issue
happens.
As it is possible that the issue lies within TSM - did you review
relevant TSM logs ?
Regards
tilman
> Hi all
>
> Every now and then (about twice a week) I have an issue whereby
> a log backup using onbar -b -l to TSM seems to hang, or take a very
> long time to complete. This means that subsequent log backups fail,
> with the message about cannot start a log backup because another
> one is already running. The 'fix' is to kill the hanging onbar
> process, whereby another starts and all the stacked-up logs
> back up OK. I'm going to set BAR_DEBUG today but I was just
> wondering if anyone's seen a similar issue?
>
> Thanks.
>
> J.
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
>
tilleul17@web.de wrote:
> JPM wrote:
>
> bar_act.log and//or bar_debug.log might give you a hint what's happening.
> Also, try to catch a stack of the ontape process when the issue
> happens.
>
> As it is possible that the issue lies within TSM - did you review
> relevant TSM logs ?
>
> Regards
> tilman
>
>> Hi all
>>
>> Every now and then (about twice a week) I have an issue whereby
>> a log backup using onbar -b -l to TSM seems to hang, or take a very
>> long time to complete. This means that subsequent log backups fail,
>> with the message about cannot start a log backup because another
>> one is already running. The 'fix' is to kill the hanging onbar
>> process, whereby another starts and all the stacked-up logs
>> back up OK. I'm going to set BAR_DEBUG today but I was just
>> wondering if anyone's seen a similar issue?
>>
>> Thanks.
>>
>> J.
>> _______________________________________________
>> Informix-list mailing list
>> Informix-list@iiug.org
>> http://www.iiug.org/mailman/listinfo/informix-list
>>
>
I'd like to second these thoughts. I have been through a real nightmare
with OnBar with a certain SM (not TSM), and the quick conclusion is that
it's very easy to be lost in this kind of issues... I will blog about
this. A stack trace of the process and a truss/strace might bring some
light over the issue.
If a certain time (600s?) pass after a call to the BSA library
functions, onbar will start complaining about it in the bar_act_log. But
it will not abort the backup. The error ask the operator/administrator
to see what is happening with the SM. In my situation the SM was waiting
on a system call which had a bug (!)...
Regards and good luck.
On 8 Sep, 00:12, Fernando Nunes <domusonl...@gmail.com> wrote:
> tilleu...@web.de wrote:
> > JPM wrote:
>
> > bar_act.log and//or bar_debug.log might give you a hint what's happening.
> > Also, try to catch a stack of the ontape process when the issue
> > happens.
>
> > As it is possible that the issue lies within TSM - did you review
> > relevant TSM logs ?
>
> > Regards
> > tilman
>
> >> Hi all
>
> >> Every now and then (about twice a week) I have an issue whereby
> >> a log backup using onbar -b -l to TSM seems to hang, or take a very
> >> long time to complete. This means that subsequent log backups fail,
> >> with the message about cannot start a log backup because another
> >> one is already running. The 'fix' is to kill the hanging onbar
> >> process, whereby another starts and all the stacked-up logs
> >> back up OK. I'm going to set BAR_DEBUG today but I was just
> >> wondering if anyone's seen a similar issue?
>
> >> Thanks.
>
> >> J.
> >> _______________________________________________
> >> Informix-list mailing list
> >> Informix-l...@iiug.org
> >>http://www.iiug.org/mailman/listinfo/informix-list
>
> I'd like to second these thoughts. I have been through a real nightmare
> with OnBar with a certain SM (not TSM), and the quick conclusion is that
> it's very easy to be lost in this kind of issues... I will blog about
> this. A stack trace of the process and a truss/strace might bring some
> light over the issue.
> If a certain time (600s?) pass after a call to the BSA library
> functions, onbar will start complaining about it in the bar_act_log. But
> it will not abort the backup. The error ask the operator/administrator
> to see what is happening with the SM. In my situation the SM was waiting
> on a system call which had a bug (!)...
>
> Regards and good luck.
Yes 600s BAR_TIMEOUT and this is NOT configurable.
http://seer.entsupport.symantec.com/docs/270284.htm
http://www.iiug.org/forums/ids/index.cgi/noframes/read/12114