How does onbar use tmpdbs during a backup?
Posted in 2010
Topics: Backup & Restore, Storage & Space Management, Server Administration, Platform-Specific Issues
Are the statements below true : IDS7.31.UD8 and AIX 5.3. Please share your thoughts and feedbacks! Onbar =A0consumes =A0temp dbspace. =A0It sorts every before image page = into the temp table which created for each dbspaces. Onbar =A0frees the temp table after the dbspace has been backed up, but= with heavy activity on the instance, if there are many dbspaces with big chu= nks, there will not be enough temp dbspaces for completing the archive. The problem of an archive aborting with the 'Error 131, =A0no free disk= space' error, occurs as a result of Online running out of disk space while writing pages to a temp table. A temp t= able for each dbspace is created when the archive process is started. These = temp tables contains pages that have been modified since the archive started= . After an individual dbspace is backed up, the corresponding temp table = will then be backed up and dropped. This same process is repeated for each dbspace. Thanks for your anticipated answers. jp=
Original post: Are the statements below true : IDS7.31.UD8 and AIX 5.3. Please share your thoughts and feedbacks! Onbar =A0consumes =A0temp dbspace. =A0It sorts every before image page = into the temp table which created for each dbspaces. Onbar =A0frees the temp table after the dbspace has been backed up, but= with heavy activity on the instance, if there are many dbspaces with big chu= nks, there will not be enough temp dbspaces for completing the archive. The problem of an archive aborting with the 'Error 131, =A0no free disk= space' error, occurs as a result of Online running out of disk space while writing pages to a temp table. A temp t= able for each dbspace is created when the archive process is started. These = temp tables contains pages that have been modified since the archive started= . After an individual dbspace is backed up, the corresponding temp table = will then be backed up and dropped. This same process is repeated for each dbspace. Thanks for your anticipated answers. jp= Response: Yes, the 1st statement is true, while an archive is in process, if the dbspace is currently not backed up yet, before images of pages from that dbspace will not only go into the physical log when they are modified, but also into a separate "temp" table that the archive process creates. The 2nd statement is also true that when a dbspace has been backed up, the "temp" table for those before images is dropped. However, the 2nd portion of the 2nd statement could be true, it would depend on how big your dbspaces were, how active the system was, and how much space is allocated to tempdbspaces. Lastly, yes the 3rd statement could also be true. I'm not 100% certain that the only reason an archive could fail with a 131 error would be the temp dbspaces were full, but it is very likely to be the most common reason if you are attempting to archive a very active system that is also very large with not enough temp dbspace space allocated. Jacques Renaut IBM Informix Advanced Support APD Team