oninit: Fatal error in shared memory initialization
Posted in 2007
Topics: Storage & Space Management, Error Codes & Troubleshooting, Server Administration, Logging & Checkpoints
Hello - Any thoughts on what could be causing this error:
The DBA was attempting to turn on "logical logging" (???), but now he
is gone for the weekend and the system is down and I am just trying to
find a temp workaround...Thank you!
(Linux with IDS 10)
>From the oninit -v process:
....
Forking 1 'ipcshm' listener threads...succeeded
Forking 1 'soctcp' listener threads...succeeded
Starting tracing...succeeded
Initializing 8 flushers...succeeded
Initializing log/checkpoint information...FAILED
oninit: Fatal error in shared memory initialization
>From the online.log:
Fri Jan 26 15:46:48 2007
15:46:48 Event alarms enabled. ALARMPROG =
'/usr/informix/etc/no_log.sh'
15:46:48 Booting Language <c> from module <>
15:46:48 Loading Module <CNULL>
15:46:48 Booting Language <builtin> from module <>
15:46:48 Loading Module <BUILTINNULL>
15:46:54 DR: DRAUTO is 0 (Off)
15:46:54 IBM Informix Dynamic Server Version 10.00.UC5 SoftwareSerial Number AAA#B000000
15:46:54 Assert Warning: I/O bad request chunk 1, pagenum 995264,pagecnt 1
15:46:54 IBM Informix Dynamic Server Version 10.00.UC5
15:46:54 Who: Session(1, root@wendy, 0, 0x4d5bd018)
Thread(21, main_loop(), 4d593018, 1)
File: rsbuff.c Line: 5412
15:46:54 Action: Please notify IBM Informix Technical Support.
15:46:54 stack trace for pid 6512 written to
/usr/informix/tmp/af.3fd68be
15:46:54 See Also: /usr/informix/tmp/af.3fd68be
15:46:54 I/O bad request chunk 1, pagenum 995264, pagecnt 1
15:46:55 IBM Informix Dynamic Server Stopped.
15:46:55 mt_shm_remove: WARNING: may not have removed all/correctsegments
There is possibly more infomation worth posting in the file
/usr/informix/tmp/af.3fd68be. You might want to run an oncheck -pr and
make sure that none of the chunks of the system are marked down. If
you do have non mirrored chunks that are down, you would likely have to
call into tech support and have them do something about it.
Looks , you also have memory segments problem.
Run "ipcs" , there should be no line for "informix" if IDS is shut down.
Otherwise, you may need run "ipcrm" to remove the segments first.
Frank
On 26 Jan 2007 12:59:32 -0800, debbie@diversifiedmetals.com <
debbie@diversifiedmetals.com> wrote:
>
> Hello - Any thoughts on what could be causing this error:
>
> The DBA was attempting to turn on "logical logging" (???), but now he
> is gone for the weekend and the system is down and I am just trying to
> find a temp workaround...Thank you!
>
> (Linux with IDS 10)
>
> >From the oninit -v process:
> ....
> Forking 1 'ipcshm' listener threads...succeeded
> Forking 1 'soctcp' listener threads...succeeded
> Starting tracing...succeeded
> Initializing 8 flushers...succeeded
> Initializing log/checkpoint information...FAILED
> oninit: Fatal error in shared memory initialization
>
> >From the online.log:
>
> Fri Jan 26 15:46:48 2007
>
> 15:46:48 Event alarms enabled. ALARMPROG =
> '/usr/informix/etc/no_log.sh'
> 15:46:48 Booting Language <c> from module <>
> 15:46:48 Loading Module <CNULL>
> 15:46:48 Booting Language <builtin> from module <>
> 15:46:48 Loading Module <BUILTINNULL>
> 15:46:54 DR: DRAUTO is 0 (Off)
> 15:46:54 IBM Informix Dynamic Server Version 10.00.UC5 Software> Serial Number AAA#B000000
> 15:46:54 Assert Warning: I/O bad request chunk 1, pagenum 995264,> pagecnt 1
> 15:46:54 IBM Informix Dynamic Server Version 10.00.UC5
> 15:46:54 Who: Session(1, root@wendy, 0, 0x4d5bd018)
> Thread(21, main_loop(), 4d593018, 1)
> File: rsbuff.c Line: 5412
> 15:46:54 Action: Please notify IBM Informix Technical Support.
> 15:46:54 stack trace for pid 6512 written to
> /usr/informix/tmp/af.3fd68be
> 15:46:54 See Also: /usr/informix/tmp/af.3fd68be
> 15:46:54 I/O bad request chunk 1, pagenum 995264, pagecnt 1
> 15:46:55 IBM Informix Dynamic Server Stopped.
>
> 15:46:55 mt_shm_remove: WARNING: may not have removed all/correct> segments
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
>
Looks to me like a permissions or physical error on your first chunk.
If you grep for ROOTPATH from $INFORMIXDIR/etc/$ONCONFIG and ls -lL the
results of that, what do you get?
<debbie@diversifiedmetals.com> wrote in message
news:1169845172.755080.55970@j27g2000cwj.googlegroups.com...
> Hello - Any thoughts on what could be causing this error:
>
> The DBA was attempting to turn on "logical logging" (???), but now he
> is gone for the weekend and the system is down and I am just trying to
> find a temp workaround...Thank you!
>
> (Linux with IDS 10)
>
>>From the oninit -v process:
> ....
> Forking 1 'ipcshm' listener threads...succeeded
> Forking 1 'soctcp' listener threads...succeeded
> Starting tracing...succeeded
> Initializing 8 flushers...succeeded
> Initializing log/checkpoint information...FAILED
> oninit: Fatal error in shared memory initialization
>
>>From the online.log:
>
> Fri Jan 26 15:46:48 2007
>
> 15:46:48 Event alarms enabled. ALARMPROG =
> '/usr/informix/etc/no_log.sh'
> 15:46:48 Booting Language <c> from module <>
> 15:46:48 Loading Module <CNULL>
> 15:46:48 Booting Language <builtin> from module <>
> 15:46:48 Loading Module <BUILTINNULL>
> 15:46:54 DR: DRAUTO is 0 (Off)
> 15:46:54 IBM Informix Dynamic Server Version 10.00.UC5 Software> Serial Number AAA#B000000
> 15:46:54 Assert Warning: I/O bad request chunk 1, pagenum 995264,> pagecnt 1
> 15:46:54 IBM Informix Dynamic Server Version 10.00.UC5
> 15:46:54 Who: Session(1, root@wendy, 0, 0x4d5bd018)
> Thread(21, main_loop(), 4d593018, 1)
> File: rsbuff.c Line: 5412
> 15:46:54 Action: Please notify IBM Informix Technical Support.
> 15:46:54 stack trace for pid 6512 written to
> /usr/informix/tmp/af.3fd68be
> 15:46:54 See Also: /usr/informix/tmp/af.3fd68be
> 15:46:54 I/O bad request chunk 1, pagenum 995264, pagecnt 1
> 15:46:55 IBM Informix Dynamic Server Stopped.
>
> 15:46:55 mt_shm_remove: WARNING: may not have removed all/correct> segments
>
Phone Tech support,
something is terribly wrong with page
> 15:46:54 Assert Warning: I/O bad request chunk 1, pagenum 995264,
some info should also be in:> /usr/informix/tmp/af.3fd68be
or restore from archive
Superboer.
On 26 jan, 21:59, deb...@diversifiedmetals.com wrote:
> Hello - Any thoughts on what could be causing this error:
>
> The DBA was attempting to turn on "logical logging" (???), but now he
> is gone for the weekend and the system is down and I am just trying to
> find a temp workaround...Thank you!
>
> (Linux with IDS 10)
>
> >From the oninit -v process:....
> Forking 1 'ipcshm' listener threads...succeeded
> Forking 1 'soctcp' listener threads...succeeded
> Starting tracing...succeeded
> Initializing 8 flushers...succeeded
> Initializing log/checkpoint information...FAILED
> oninit: Fatal error in shared memory initialization
>
> >From the online.log:Fri Jan 26 15:46:48 2007
>
> 15:46:48 Event alarms enabled. ALARMPROG =
> '/usr/informix/etc/no_log.sh'
> 15:46:48 Booting Language <c> from module <>
> 15:46:48 Loading Module <CNULL>
> 15:46:48 Booting Language <builtin> from module <>
> 15:46:48 Loading Module <BUILTINNULL>
> 15:46:54 DR: DRAUTO is 0 (Off)
> 15:46:54 IBM Informix Dynamic Server Version 10.00.UC5 Software> Serial Number AAA#B000000
> 15:46:54 Assert Warning: I/O bad request chunk 1, pagenum 995264,> pagecnt 1
> 15:46:54 IBM Informix Dynamic Server Version 10.00.UC5
> 15:46:54 Who: Session(1, root@wendy, 0, 0x4d5bd018)
> Thread(21, main_loop(), 4d593018, 1)
> File: rsbuff.c Line: 5412
> 15:46:54 Action: Please notify IBM Informix Technical Support.
> 15:46:54 stack trace for pid 6512 written to
> /usr/informix/tmp/af.3fd68be
> 15:46:54 See Also: /usr/informix/tmp/af.3fd68be
> 15:46:54 I/O bad request chunk 1, pagenum 995264, pagecnt 1
> 15:46:55 IBM Informix Dynamic Server Stopped.
>
> 15:46:55 mt_shm_remove: WARNING: may not have removed all/correct> segments
Related threads
- the longer you surf, the MORE $$$ you earn !!
- Store procedure
- emulation for Vt100
- extent size questions again ...