Re: Any assistance appreciated: Dynamic Server Initialisation Failure
Posted in 2005
--0-229833697-1106363026=:39551
Content-Type: text/plain; charset=us-ascii
Just a thought Burton,
Did you check to make sure there are no oninit processes hung out there ?
ps -ef |grep oninit,
also ipcs make sure no shm segments are hung.
As a last resort, you may also try rebooting the box.
Obnoxio The Chav <obnoxio@serendipita.com> wrote:
Burton, Clifford said:
>
> I have a situation where the IDS-731UD4 instance I run on HP-UX 11 is
> failing after a cold restore.
Are the permissions on your disk chunks OK? Are they the same names as
before? Are your Informix binary and library permissions correct? Is your
/etc/services still kosher (or halaal or whatever)?
HTH.
> I do not have time to perform another restore without serious business
> ramifications.
>
> The output from the log file is: the last lines:
> 09:47:30 Could not create single shared memory segment with resident and
> non-re sident partitions. Proceeding to create 2 shared memory segments
> instead.
> 09:47:32 Segment locked: addr=0xc1841000, size=683679744
>
> Sat Jan 22 09:47:32 2005
>
> 09:47:32 Event alarms enabled. ALARMPROG =
> '/apps/informix_ids/etc/ifx_alert.sh'
> 09:47:38 DR: DRAUTO is 0 (Off)
> 09:47:39 Dynamically allocated new message shared memory segment (size
> 1104KB)
>
> 09:47:39 Informix Dynamic Server Version 7.31.UD1 Software Serial
> Number
> AAD
> #J216570
> 09:47:39 Informix Dynamic Server Initialized -- Shared Memory
> Initialized.
> 09:47:39 Physical Recovery Started.
> 09:47:39 Physical Recovery Complete: 0 Pages Restored.
> 09:47:39 Logical Recovery Started.
> 09:47:42 Logical Recovery Complete.
> 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> However:
>
> informix@machinename$ onstat -> shared memory not initialized for INFORMIXSERVER 'newworld'
>
> The results of the oninit -v are:
>
> Checking group membership to determine server run modesucceeded Reading
> configuration file '/apps/informix_ids/etc/onconfig.newworld'...succeeded
> Creating /INFORMIXTMP/.infxdirs ... succeeded Creating infos file
> "/apps/informix_ids/etc/.infos.newworld" ...
> "/apps/informix_ids/etc/.conf.newworld" ... succeeded Writing to infos
> file
> ... succeeded Checking config parameters...succeeded Allocating and
> attaching to shared memory...succeeded Creating resident pool 143252
> kbytes...succeeded Creating buffer pool 524290 kbytes...succeeded
> Initializing rhead structure...succeeded Initializing ASF ...succeeded
> Initializing Dictionary Cache and Stored Procedure Cache...succeeded
> Bringing up ADM VP...succeeded Creating VP classes...succeeded Onlining 4
> additional cpu vps...succeeded Onlining 18 IO vps...succeeded Forking
> main_loop thread...succeeded Initialzing DR structures...succeeded Forking
> 1
> 'ipcshm' listener threads...succeeded Forking 2 'soctcp' listener
> threads...succeeded Forking 1 'ipcshm' listener threads...succeeded
> Forking
> 0 'soctcp' listener threads...succeeded Forking 0 'soctcp' listener
> threads...succeeded Starting tracing...succeeded Initializing 32
> flushers...succeeded Initializing log/checkpoint information...succeeded
> Opening primary chunks...succeeded Opening mirror chunks...succeeded
> Initializing dbspaces...succeeded Validating chunks...succeeded Initialize
> Async Log Flusher...succeeded Forking btree cleaner...succeeded
> Initializing
> DBSPACETEMP list Checking database partition index...FAILED
> oninit: Fatal error in shared memory initialization
>
>
> I realise that it is unlikely that too many people are out there right at
> this moment, however, I have been working on this issue so long now that I
> am loosing track of time, Does anyone have any ideas as to how to get this
> online, I do have a vague recollection of an issue like this in the past
> that was resolved quite simply. I am attempting to contact IBM Support on
> the issue although it is a moderately complex task out of hours when I
> cannot locate the support contracts etc...
>
> Clifford Burton
> Senior Database Administrator
> SIMplus Mobile Pty Ltd [ www.SIMplus.com.au
> ]
> Ph: (02) 9028 1716
> Fx: (02) 9030 6284
>
> Em: Clifford_Burton@SIMplus.com.au
>
> SIMplus Mobile Pty Ltd ABN 37 098 145 218.
> SIMplus is the trademark of SingTel Optus Ltd trading as Optus
> Communications.
>
> ----------------------------------------------------
>
> This message is for the named person's use only.
>
> Privileged/confidential information may be contained in
> this message. If you are not the addressee indicated in
> this message (or responsible for delivery of the message
> to such person), you may not copy or deliver this
> message to anyone. In such case, you should destroy
> this message, and notify us immediately.
>
> Any views expressed in this message are those of the
> individual sender, except where the message states
> otherwise and the sender is authorised to state them to
> be the views of any such entity.
> ----------------------------------------------------
> sending to informix-list
>
--
Bye now,
Obnoxio
"C'est pas parce qu'on n'a rien ' dire qu'il faut fermer sa gueule"
- Coluche
"I'm trying to see things your way, but I can't get my head up my ass"
- JCH
"Ogni uomo mi guarda come se fossi una testa di cazzo"
- Marco
If anyone told you to be yourself they would be giving you bad advice.
I went to the airport to check in and they asked what I did because I
looked like a terrorist. I said I was a comedian. They said, "Say
something funny then." I told them I had just graduated from flying
school.
-- Ahmed Ahmed
sending to informix-list
========================
-<<Floyd Wellershaus>>-
Database Administrator
Unix Administrator
email: fwellers@yahoo.com
Work: 703-733-4126
Pager: 703-705-9241
Email Pager: 7037059241@my2way.com
Home: 703-430-0805
Cell: 703-477-6045
========================
--0-229833697-1106363026=:39551
Content-Type: text/html; charset=us-ascii
<DIV>Just a thought Burton, </DIV>
<DIV>Did you check to make sure there are no oninit processes hung out there ?</DIV>
<DIV>ps -ef |grep oninit,</DIV>
<DIV>also ipcs make sure no shm segments are hung.</DIV>
<DIV> </DIV>
<DIV>As a last resort, you may also try rebooting the box.</DIV>
<DIV><BR><BR><B><I>Obnoxio The Chav <obnoxio@serendipita.com></I></B> wrote:</DIV>
<BLOCKQUOTE class=replbq style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #1010ff 2px solid"><BR>Burton, Clifford said:<BR>><BR>> I have a situation where the IDS-731UD4 instance I run on HP-UX 11 is<BR>> failing after a cold restore.<BR><BR>Are the permissions on your disk chunks OK? Are they the same names as<BR>before? Are your Informix binary and library permissions correct? Is your<BR>/etc/services still kosher (or halaal or whatever)?<BR><BR>HTH.<BR><BR>> I do not have time to perform another restore without serious business<BR>> ramifications.<BR>><BR>> The output from the log file is: the