fei shq via DBMonster.com said:
> In my programs wrote in ESQLC, error -25588 encountered.
> My program forks several child processes,db connection is established in
> every process and keep alive till end of process.
> When I fork more processes, certain process will fail to establish
> connection to informix server(IDS 7.31).
> Since my program deployed on the same computer with IDS, we use onipcshm
> as
> commumication protocol.If I change onipcshm to onsoctcp,no 25588 error
> occur.
> What's the reason?
> Help me,pls.
A good place to start would be to give *exact* client and server software
versions: for example 7.31.FC4 and CSDK 2.70.UC2
--
Bye now,
Obnoxio
"C'est pas parce qu'on n'a rien ' dire qu'il faut fermer sa gueule"
- Coluche
"I'm trying to see things your way, but I can't get my head up my ass"
- JCH
"Ogni uomo mi guarda come se fossi una testa di cazzo"
- Marco
Travel broadens a person. You look as if you have been all over the world.
I went to the airport to check in and they asked what I did because I
looked like a terrorist. I said I was a comedian. They said, "Say
something funny then." I told them I had just graduated from flying
school.
-- Ahmed Ahmed
http://i2.photobucket.com/albums/y41/Obnoxio/thinkIfoundtheproblem.jpg
sending to informix-list
↪ replying to Obnoxio The Chav
thanks a lot.
IDS version:7.31.UD2R1
ESQL:INFORMIX-ESQL Version 9.51.HC3
I'm sorry to forget clientsdk version,seems to be 2.81.
--
Message posted via http://www.dbmonster.com