25590: Authentication error.
Posted in 2017
User reported error 25590 (Authentication error) when Active Directory users attempted to connect to Informix IDS 12.10.FC9TL via dbaccess on CentOS 6.9, while local users connected successfully. AD users were valid at OS level. A responder suggested checking if CSM (Client/Server Mode) option was mismatched between server and client. No resolution was confirmed in the thread.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Server Administration, Networking & sqlhosts Configuration
Hello
OS Version : CentOS release 6.9
Informix version : IDS 12.10.FC9TL
We are having issues connecting to our Informix database through dbaccess
Users created locally on the server can connect successfully to the database.
However all 'Active Directory ' users receive error message (25590:
Authentication error) while trying to connect to the database.
There is no information logged in the online.log file regarding connection
issues
Below the content of the sqlhost file.
ol_informix1210 onsoctcp servername 22805
Any clues?
Regards
Are the users identified to the OS? IE, if you issue 'id username' were username is a user from AD, do you get a valid response?
Pete Yes the users are identified to the OS. They can connect to the server. If I issue and 'id username' where username is a user from AD, yes I get a valid response containing the uid and the gid -----Message d'origine----- De : ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] De la part de PETE MCDONNELL Envoyé : 18 octobre 2017 10:51 À : ids@iiug.org Objet : Re: 25590: Authentication error. [40087] Are the users identified to the OS? IE, if you issue 'id username' were username is a user from AD, do you get a valid response? ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
Is what you provided the server's sqlhosts file?
From: "Mouhamadou Dia" <MDia@accovia.com>
To: ids@iiug.org
Date: 10/18/2017 04:17 PM
Subject: 25590: Authentication error. [40086]
Sent by: ids-bounces@iiug.org
Hello
OS Version : CentOS release 6.9
Informix version : IDS 12.10.FC9TL
We are having issues connecting to our Informix database through dbaccess
Users created locally on the server can connect successfully to the
database.
However all 'Active Directory ' users receive error message (25590:
Authentication error) while trying to connect to the database.
There is no information logged in the online.log file regarding connection
issues
Below the content of the sqlhost file.
ol_informix1210 onsoctcp servername 22805
Any clues?
Regards
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
yes
-----Message d'origine-----
De : ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] De la part de Andreas
Legner1
Envoyé : 18 octobre 2017 11:43
À : ids@iiug.org
Objet : Re: 25590: Authentication error. [40089]
Is what you provided the server's sqlhosts file?
From: "Mouhamadou Dia" <MDia@accovia.com>
To: ids@iiug.org
Date: 10/18/2017 04:17 PM
Subject: 25590: Authentication error. [40086] Sent by: ids-bounces@iiug.org
Hello
OS Version : CentOS release 6.9
Informix version : IDS 12.10.FC9TL
We are having issues connecting to our Informix database through dbaccess
Users created locally on the server can connect successfully to the database.
However all 'Active Directory ' users receive error message (25590:
Authentication error) while trying to connect to the database.
There is no information logged in the online.log file regarding connection
issues
Below the content of the sqlhost file.
ol_informix1210 onsoctcp servername 22805
Any clues?
Regards
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
It's also not quite clear when you say AD users cannot connect (while l=
ocal
users can connect using dbaccess):
are AD user connection attempts local (using dbaccess too) or remote (u=
sing
what)?
Your sqlhosts entry, without any bells and whistles (special auth optio=
ns),
doesn't look like it ever should be yielding a -- server side -- - 255=
90.
Maybe the last part of the following (from 'finderr 25590') applies?
This error can also occur if the CSM option is enabled on the database
server side but disabled on the client application side, or vice versa.=
HTH,
Andreas
From: "Mouhamadou Dia" <MDia@accovia.com>
To: ids@iiug.org
Date: 10/18/2017 06:02 PM
Subject: RE: 25590: Authentication error. [40090]
Sent by: ids-bounces@iiug.org
yes
-----Message d'origine-----
De : ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] De la part de
Andreas
Legner1
Envoy=E9 : 18 octobre 2017 11:43
=C0 : ids@iiug.org
Objet : Re: 25590: Authentication error. [40089]
Is what you provided the server's sqlhosts file?
From: "Mouhamadou Dia" <MDia@accovia.com>
To: ids@iiug.org
Date: 10/18/2017 04:17 PM
Subject: 25590: Authentication error. [40086] Sent by: ids-bounces@iiug=
.org
Hello
OS Version : CentOS release 6.9
Informix version : IDS 12.10.FC9TL
We are having issues connecting to our Informix database through dbacce=
ss
Users created locally on the server can connect successfully to the
database.
However all 'Active Directory ' users receive error message (25590:
Authentication error) while trying to connect to the database.
There is no information logged in the online.log file regarding connect=
ion
issues
Below the content of the sqlhost file.
ol_informix1210 onsoctcp servername 22805
Any clues?
Regards
***********************************************************************=
********
Forum Note: Use "Reply" to post a response in the discussion forum.
***********************************************************************=
********
Forum Note: Use "Reply" to post a response in the discussion forum.
***********************************************************************=
********
Forum Note: Use "Reply" to post a response in the discussion forum.
=