onipcstr
Posted in 2015
Topics: Networking & sqlhosts Configuration
I am using 12.10FC3XR. I have a server with onipcstr for local connections in my sqlhosts file. I also have an onsoctcp for network connections. Network connections work fine. Any kind of local connection results in Unix Error 9 - Bad file number. If I change the file name in the service name field in sqlhosts to some other name and restart the server all is well. If change back to the original file name I get the error again. So I'm very clear as to the problem (and an easy fix), however, in order to ensure I don't have the problem again, I'm keen to understand the issue better. The documentation (admin guide Ch 2 page 2-23) says the file name can be "... any short group of letters that is unique in the environment of the host computer ..." Does anyone know what this actually means? I have checked the file system for any file of either of the names I am using and find none. So what is this "file"? where does it live? What does the documentation mean by "environment"? Is it really a file? Any help will be much appreciated.
I would check the /INFORMIXTMP directory. This is where the stream gets created by default. There could be a permission problem or other issues with the stream. John F. Miller III STSM, Lead Architect miller3@us.ibm.com 503-747-1366 IBM Informix Dynamic Server (IDS) ids-bounces@iiug.org wrote on 02/03/2015 03:17:31 PM: > From: "RAY BURNS" <ray.burns@velocityglobal.co.nz> > To: ids@iiug.org > Date: 02/03/2015 03:18 PM > Subject: onipcstr [34555] > Sent by: ids-bounces@iiug.org > > I am using 12.10FC3XR. > > I have a server with onipcstr for local connections in my sqlhosts file. I > also have an onsoctcp for network connections. > > Network connections work fine. Any kind of local connection results in Unix > Error 9 - Bad file number. > > If I change the file name in the service name field in sqlhosts to some other > name and restart the server all is well. If change back to the original file > name I get the error again. So I'm very clear as to the problem (and an easy > fix), however, in order to ensure I don't have the problem again, I'm keen to > understand the issue better. > > The documentation (admin guide Ch 2 page 2-23) says the file name can be "... > any short group of letters that is unique in the environment of the host > computer ..." > > Does anyone know what this actually means? I have checked the file system for > any file of either of the names I am using and find none. So what is this > "file"? where does it live? What does the documentation mean by > "environment"? > Is it really a file? > > Any help will be much appreciated. > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. >
Many thanks John, this has headed me in the right direction.
Can you tell me when the file gets created? Is it during oninit?
Is it safe to shutdown the database, and delete the files from the directory
and then restart? Will they get re-built?
have a try restart the listener
- shut down the ipcstr listener
onmode -P stop <IPCSTR DBSERVERALIAS NAME>- start the ipcstr listener
onmode -P start <IPCSTR DBSERVERALIAS NAME>
Thank you both for your replies. I have it all working now. Deleting and the files and restarting did the trick.