Disabled Temp DBspace -- Revisited
Posted in 1997
This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.
------ =_NextPart_000_01BCD4CA.3A5E4470
Content-Type: text/plain;
charset="iso-8859-1"
Hello All,
We're running ODS 7.20.UC3 on a DEC 8200, O/S version 3.2.
Summary:
Following an assert failure / segmentation violation that brought down
the engine,
we rebooted the box. Recovery failed on a chunk in a temp dbspace. Now
the
chunk / dbspace is marked DOWN. For a workaround, we re-assigned the
DBSPACETEMP to another dbspace/chunk, then bounced the instance.
The interesting part:
Browsing thru dejanews, I found that someone else had this problem over
a YEAR ago
on an AIX 4.1 platform w/ ODS 7.12.UC2. There was speculation then that
the problem
would be fixed in 7.2x. Obviously, it has not been fixed, at least not
on the DEC platform.
Question: Has anyone else had this problem?? Any cures??
For those interested, here are the gory details:
...
14:28:03 Checkpoint Completed: duration was 0 seconds.
14:33:03 Checkpoint Completed: duration was 0 seconds.
14:34:42 Assert Failed: Internal Error - Segmentation Violation
14:34:42 Who: Session(1319, userid@<UNKNOWN-HOST>, -1, 118598248)
Thread(1355, sqlexec, 5d5b1f8, 3)
14:34:42 Results: OnLine must abort
14:34:42 Action: Reinitialize shared memory
14:34:42 See Also: /tmp/af.54b5971
14:34:42 rsinit.c, line 9640, thread 1355, proc id 25164, Segmentation
Violation.
14:34:42 PANIC: Attempting to bring system down
Mon Oct 6 15:22:48 1997
15:22:48 Event alarms enabled. ALARMPROG =
'/opt/informix/prod/log_full_dq1.sh'
15:22:52 DR: DRAUTO is 0 (Off)
15:22:54 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
15:22:54 Physical Recovery Started.
15:22:55 Physical Recovery Complete: 64 Pages Restored.
15:22:55 Logical Recovery Started.
15:22:56 Assert Failed: WARNING! pthdrpage:ptalloc:bad partn page
15:22:56 Who: Session(24, informix@infx_srvr, 0, 97903240)
Thread(56, xchg_1.4, 5d32218, 3)
15:22:56 Results: Cannot use TBLSpace page for TBLSpace 11534374
15:22:56 Action: Run 'oncheck -pt 11534374'
<<< NOTE: Here's where the real problem began.
<<< This "oncheck" just gave us:
<<< Error opening TBLspace b00026. ??????
15:22:56 See Also: /tmp/af.3864bf
15:22:56 Rollforward of log record failed. iserrno = 101
15:22:56 Log Record: log = 429, pos = 4337e0, type = 91[PTCOLUMN],trans = 157
15:22:56 Process exited with return code 1: /bin/sh /bin/sh -c
/opt/informix/prod/log_full_dq1.sh 3 1 "Table failure:
'dq1p:"aboivin"._temptable'." "pthdrpage:ptallo
15:22:57 Assert Failed: WARNING! Chunk 11 is being taken OFFLINE.
15:22:57 Who: Session(24, informix@infx_srvr, 0, 97900040)
Thread(56, xchg_1.4, 5d32218, 3)
15:22:57 Results: DBspace dq1tmp02s is disabled.
15:22:57 Action: Restore DBspace dq1tmp02s
<<< NOTE: Tried to do this restore of dq1tmp02s (a temp dbspace) --
didn't work!!
15:22:57 See Also: /tmp/af.3864bf
15:22:57 Logical Recovery Complete. 20 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
15:22:57 Assert Failed: Memory freed at bad boundary. 2432 bytes at2062a5680
15:22:57 Who: Session(24, informix@infx_srvr, 0, 0)
Thread(49, fast_rec, 0, 5)
15:22:57 Results: Memory lost
15:22:57 Action: Action: %s
15:22:57 See Also: /tmp/af.3164c1
15:22:57 Dataskip is now ON for all dbspaces
15:22:58 On-Line Mode
15:22:58 Checkpoint Completed: duration was 0 seconds.
15:22:58 Process exited with return code 1: /bin/sh /bin/sh -c
/opt/informix/prod/log_full_dq1.sh 4 5 "DBspace is off-line:'dq1tmp02s'." "Chunk 11 is being taken OF
<<< NOTE: Chunk 11 is the only one in that temp dbspace.
15:28:26 Checkpoint Completed: duration was 0 seconds.
15:33:26 Checkpoint Completed: duration was 0 seconds.
[SNIP]
16:08:26 Checkpoint Completed: duration was 0 seconds.
16:13:26 Checkpoint Completed: duration was 0 seconds.
16:18:07 Skipped existing audit trail /onaudit/infx_srvr1_shm.0.
16:18:07 Process exited with return code 1: /bin/sh /bin/sh -c
/opt/informix/prod/log_full_dq1.sh 2 6 "Internal Subsystem failure:'Audit'" "Skipped existing audit t
16:18:07 Skipped existing audit trail /onaudit/infx_srvr1_shm.1.
16:18:07 Process exited with return code 1: /bin/sh /bin/sh -c
/opt/informix/prod/log_full_dq1.sh 2 6 "Internal Subsystem failure:'Audit'" "Skipped existing audit t
16:18:07 Skipped existing audit trail /onaudit/infx_srvr1_shm.2.
16:18:07 Process exited with return code 1: /bin/sh /bin/sh -c
/opt/informix/prod/log_full_dq1.sh 2 6 "Internal Subsystem failure:'Audit'" "Skipped existing audit t
16:18:07 Skipped existing audit trail /onaudit/infx_srvr1_shm.3.
16:18:07 Process exited with return code 1: /bin/sh /bin/sh -c
/opt/informix/prod/log_full_dq1.sh 2 6 "Internal Subsystem failure:'Audit'" "Skipped existing audit t
16:18:07 Skipped existing audit trail /onaudit/infx_srvr1_shm.4.
16:18:07 Process exited with return code 1: /bin/sh /bin/sh -c
/opt/informix/prod/log_full_dq1.sh 2 6 "Internal Subsystem failure:'Audit'" "Skipped existing audit t
16:18:07 Skipped existing audit trail /onaudit/infx_srvr1_shm.5.
16:18:07 Process exited with return code 1: /bin/sh /bin/sh -c
/opt/informix/prod/log_full_dq1.sh 2 6 "Internal Subsystem failure:'Audit'" "Skipped existing audit t
16:18:07 Skipped existing audit trail /onaudit/infx_srvr1_shm.6.
16:18:07 Process exited with return code 1: /bin/sh /bin/sh -c
/opt/informix/prod/log_full_dq1.sh 2 6 "Internal Subsystem failure:'Audit'" "Skipped existing audit t
16:18:26 Checkpoint Completed: duration was 0 seconds.
16:23:26 Checkpoint Completed: duration was 0 seconds.
16:28:26 Checkpoint Completed: duration was 0 seconds.
16:43:26 Checkpoint Completed: duration was 0 seconds.
16:48:26 Checkpoint Completed: duration was 0 seconds.
16:49:30 Warning: Invalid dbspace 'dq1tmp02s' listed in DBSPACETEMP.
16:49:31 Checkpoint Completed: duration was 0 seconds.
16:50:24 Checkpoint Completed: duration was 0 seconds.
16:50:26 INFORMIX-OnLine Stopped.
Mon Oct 6 16:50:38 1997
16:50:38 Event alarms enabled. ALARMPROG =
'/opt/informix/prod/log_full_dq1.sh'
16:50:41 DR: DRAUTO is 0 (Off)
16:50:42 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
16:50:42 Physical Recovery Started.
16:50:42 Physical Recovery Complete: 0 Pages Restored.
16:50:42 Logical Recovery Started.
16:50:45 Logical Recovery Complete. 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
16:50:45 Onconfig parameter DBSPACETEMP modified from dq1tmp02s to
dq1tmp01s.
16:50:45 Dataskip is now ON for all dbspaces
16:50:45 Checkpoint Completed: duration was 0 seconds.
16:50:45 Dropping temporary TBLspace 100067, recovering 8 pages.
16:50:45 Dropping temporary TBLspace 100068, recovering 8 pages.
16:50:45 On-Line Mode
16:56:14 Checkpoint Completed: duration was 0 seconds.
17:01:14 Checkpoint Completed: duration