Re: Help with Transaction Log !! Urgent!!!
Posted in 2004
"Madison Pruet" <mpruet@comcast.net> wrote in message
news:UWiEc.42$IQ4.28@attbi_s02...
> A lot of ISAM code is embedded in online as well. That's why we have
> SQLCODE and also return an ISAM error code in the sqlca.sqlerrd[1] field.
> Last time I checked, there were some 30 odd places in the code were we
might
> return a -121 error code.
>
??? 30 places? So how does the user determine which of the 30 places in
the
code is causing the error? So different error traps can return the same
error code?
Surely error numbers should be unique? How else can you track down the
problem?
> Just because we get an ISAM error code (including an ISAM 121) does not
mean
> that the engine is SE.
>
>
> "rkusenet" <rkusenet@sympatico.ca> wrote in message
> news:2kdf1pFsu0fU1@uni-berlin.de...
> >
> > "Madison Pruet" <mpruet@comcast.net> wrote in message
> news:dlfEc.197076$Ly.67842@attbi_s01...
> > > Are you sure about 6.05? Could you post the output of "onstat -V".
> > >
> > >
> > > No removing the txn log file is not a good idea....
> >
> > onstat !!!
> > I thought it is fairly obvious that he is talking about Standard Engine.
> > ISAM error 121 seem to be too SE centric.> >
> > >
> > >
> > > "Kishore Bhageshpur" <kishore_b@hotmail.com> wrote in message
> > > news:73ea6c9.0406290558.1933864c@posting.google.com...
> > > > Hello...
> > > >
> > > > I am using Informix 6.05 on HPUX 11.11 and whenever I try a large
> > > > update (well, anything more than about 100 records), I get the
> > > > following error
> > > > 346: Could not update a row in the table.
> > > > 121: ISAM error: cannot write log record> > > >
> > > > This database has a log file which is huge - about 25 MB. But the
> > > > file system is not full. The volume is only about 25% full. I
> > > > thought maybe the log file was too big and so tried to empty the log
> > > > file by cat /dev/null to the transaction log but I still get the
same
> > > > error message. I have no problems with selects, inserts and
deletes;
> > > > just updates.
> > > >
> > > > I am not really an Informix DBA and don't have a whole lot of
> > > > experience in Informix.., I inherited this db and any help would be
> > > > appreciated. I have already looked at previous posts on this
> > > > newsgroup, but didn't find anything which I could use.
> > > >
> > > > Would removing the transaction log completely help? How do I do
that?
> > > >
> > > > Thanks,
> > > > Kishore
> > >
> > >
> >
> >
>
>