Problem setting up Replication
Posted in 2001
Topics: Storage & Space Management, Triggers, Constraints & Referential Integrity
This message is in MIME format. Since your mail reader does not understand this format, some or all of this message may not be legible. ------_=_NextPart_000_01C08B6D.D408A4AA Content-Type: text/plain; charset="iso-8859-1" Hi, I have a problem setting up replication. I have 2 NT servers having 2 informix dynamic servers ol_dev and ol_pdc respectively. I need to replicate a database on ol_dev to ol_pdc. I have created 2 server groups g_dev containg ol_dev and g_pdc containing ol_pdc on both the servers. When i start the replication manager, i am able to start ER on each of the servers. But when i set the global catalog server to g_dev and try to commit changes in the Replication scripting view, it fails when trying to define the server g_pdc. If i set the global catalog server to g_pdc and do the same it fails when trying to define g_dev. Is the way i have created the server groups right to achieve replication. Do i need to have both the dynamic servers in the same group? Attached is the srd file. Please help. Thanks Regards Amit <<systest.srd>> ------_=_NextPart_000_01C08B6D.D408A4AA Content-Type: application/octet-stream; name="systest.srd" Content-Disposition: attachment; filename="systest.srd" Scripting View Archive ************ Definition of Servers ************** ObjectType: Server Name: g_pdc ServerType: ROOT_SERVER Sync/ParentServer: - ATSDirectory: /tmp RISDirectory: /tmp SendQueueDBSpace: rootdbs ReceiveQueueDBSpace: rootdbs IdleTimeOut(mins): 20 ObjectType: Server Name: g_dev ServerType: ROOT_SERVER Sync/ParentServer: - ATSDirectory: /tmp RISDirectory: /tmp SendQueueDBSpace: rootdbs ReceiveQueueDBSpace: rootdbs IdleTimeOut(mins): 20 ************ Definition of Replicates (Participants) ************** ObjectType: Replicate Name: SYS_replication_1 ConflictResolutionScope: TRANSACTION ConflictResolutionType: IGNORE StoredProcedureName: - Frequency Type: FREQ_INTERVAL_CHAR Hour: 0 Minute: 30 Day: 0 Month: 0 ATSSpooling: TRUE RISSpooling: TRUE CanonicalMessageFormat: TRUE FireTriggers: TRUE GroupName: - ObjectType: Participant Name: g_pdc DataBase: test Owner: informix Table: replication Primary/Target: Primary SelectStatement: Select * from informix.replication UseTableOwner: FALSE ReplicateName: SYS_replication_1 ObjectType: Participant Name: g_dev DataBase: test Owner: informix Table: replication Primary/Target: Target SelectStatement: Select * from informix.replication UseTableOwner: FALSE ReplicateName: SYS_replication_1 ------_=_NextPart_000_01C08B6D.D408A4AA--
You need to include the engine version. On NT you must set up the registery so that each server knows about the other. This is the most common reason for ER startup failures on NT. We have a tool, which I think was actually released as part of IECC that would aid in doing that. It would take a file that was set up like a sqlhosts file on UNIX and populate the NT registery. Please contact tech support for this. It's called ersched.exe. Amit Mehra wrote: > This message is in MIME format. Since your mail reader does not understand > this format, some or all of this message may not be legible. > > ------_=_NextPart_000_01C08B6D.D408A4AA > Content-Type: text/plain; > charset="iso-8859-1" > > Hi, > I have a problem setting up replication. I have 2 NT servers having 2 > informix dynamic servers ol_dev and ol_pdc respectively. I need to replicate > a database on ol_dev to ol_pdc. I have created 2 server groups g_dev > containg ol_dev and g_pdc containing ol_pdc on both the servers. > When i start the replication manager, i am able to start ER on each of the > servers. But when i set the global catalog server to g_dev and try to commit > changes in the Replication scripting view, it fails when trying to define > the server g_pdc. If i set the global catalog server to g_pdc and do the > same it fails when trying to define g_dev. > > Is the way i have created the server groups right to achieve replication. Do > i need to have both the dynamic servers in the same group? > > Attached is the srd file. > > Please help. > > Thanks > Regards > Amit > > <<systest.srd>> > > ------_=_NextPart_000_01C08B6D.D408A4AA > Content-Type: application/octet-stream; > name="systest.srd" > Content-Disposition: attachment; > filename="systest.srd" > > Scripting View Archive > > ************ Definition of Servers ************** > > ObjectType: Server > Name: g_pdc > ServerType: ROOT_SERVER > Sync/ParentServer: - > ATSDirectory: /tmp > RISDirectory: /tmp > SendQueueDBSpace: rootdbs > ReceiveQueueDBSpace: rootdbs > IdleTimeOut(mins): 20 > > ObjectType: Server > Name: g_dev > ServerType: ROOT_SERVER > Sync/ParentServer: - > ATSDirectory: /tmp > RISDirectory: /tmp > SendQueueDBSpace: rootdbs > ReceiveQueueDBSpace: rootdbs > IdleTimeOut(mins): 20 > > ************ Definition of Replicates (Participants) ************** > > ObjectType: Replicate > Name: SYS_replication_1 > ConflictResolutionScope: TRANSACTION > ConflictResolutionType: IGNORE > StoredProcedureName: - > Frequency > Type: FREQ_INTERVAL_CHAR > Hour: 0 > Minute: 30 > Day: 0 > Month: 0 > ATSSpooling: TRUE > RISSpooling: TRUE > CanonicalMessageFormat: TRUE > FireTriggers: TRUE > GroupName: - > > ObjectType: Participant > Name: g_pdc > DataBase: test > Owner: informix > Table: replication > Primary/Target: Primary > SelectStatement: Select * from informix.replication > UseTableOwner: FALSE > ReplicateName: SYS_replication_1 > > ObjectType: Participant > Name: g_dev > DataBase: test > Owner: informix > Table: replication > Primary/Target: Target > SelectStatement: Select * from informix.replication > UseTableOwner: FALSE > ReplicateName: SYS_replication_1 > > ------_=_NextPart_000_01C08B6D.D408A4AA--
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"