Error informix: Incorrect password or user informix is not known on the database server
Posted in 2000
Topics: Installation, Setup & Upgrades, Storage & Space Management, Server Administration, Security, Permissions & Auditing, Networking & sqlhosts Configuration
I am new to informix but I have read through administration manuals on
how to configure the server.
I have installed informix dynamic server and I have been unable to
connect to informix server, create a new database. I get the following
error when I try to connect or create a new database.
17:21:55 listener-thread: err = -951: oserr = 0: errstr = informix:Incorrect p
assword or user informix is not known on the database server.
/etc/password has informix user under informix group.
-------------------------------------------------------------------------------
For the patient readers longer message of adventure with informix
follows.
I was given a machine with informix installed. Directory in which
informix is installed is owned by user informix. I created a onconfig
file using onmonitor. I was able to successfully bring the server in
quiescent mode using onmonitor startup or oninit -s. onmode -m fails
with following error repeated many times inonline.log
listener-thread: err = -951: oserr = 0: errstr = informix: Incorrect
password or user informix is not known on the database server.
At the end of online.log it says that failed to build sysmaster and
points to a file in /tmp directory /tmp/buildsmi.ddd. That file also
contains a large number of errors of the following nature
951: Incorrect password or user informix is not known on the database
server.
Error in line 23Near character position 1
This error is repeated many times for different line numbers in the
script and
eventually script terminates without creating sysmaster database.
I was able to finally build the sysmaster database by logging in as root
and running onmode -m. This time sysmaster was built successfully and
now I am able to bring the server online from queiscent mode. However,
my problems continue as I am unable to connect to server and create a
new database. Through onmonitor I am able to view Profile, Userthreads,
and Spaces, however, when I choose Databases, I get the following error
Error writing to network
Cannot access database catalog TBLspace
I am not sure if onmonitor accesses the sqlhosts and /etc/services but I
have added the appropriate entries in them as follows. Name of the
machine as well as informix server is russell.
entry in $INFORMIXDIR/etc/sqlhosts
russell ontlitcp russell pd1_onentry in /etc/services
pd1_on 1543/tcp
Thanks,
Swapan
"Swapan N. Engineer" wrote:
> I am new to informix but I have read through administration manuals on
> how to configure the server.
>
> I have installed informix dynamic server and I have been unable to
> connect to informix server, create a new database. I get the following
> error when I try to connect or create a new database.
>
> 17:21:55 listener-thread: err = -951: oserr = 0: errstr = informix:> Incorrect p
> assword or user informix is not known on the database server.
>
> /etc/password has informix user under informix group.
>
> -------------------------------------------------------------------------------
>
> For the patient readers longer message of adventure with informix
> follows.
>
> I was given a machine with informix installed. Directory in which
> informix is installed is owned by user informix. I created a onconfig
> file using onmonitor. I was able to successfully bring the server in
> quiescent mode using onmonitor startup or oninit -s. onmode -m fails
> with following error repeated many times inonline.log
>
> listener-thread: err = -951: oserr = 0: errstr = informix: Incorrect
> password or user informix is not known on the database server.
>
> At the end of online.log it says that failed to build sysmaster and
> points to a file in /tmp directory /tmp/buildsmi.ddd. That file also
> contains a large number of errors of the following nature
>
> 951: Incorrect password or user informix is not known on the database
> server.
> Error in line 23> Near character position 1
>
> This error is repeated many times for different line numbers in the
> script and
> eventually script terminates without creating sysmaster database.
This is a serious problem; the system is not reliably usable until
it is fixed. You need to verify your installation -- you need a
user informix and a group informix known to the system. The majority
of the files in $INFORMIXDIR will be owned by informix, the remainder
usually by root (and these will be SUID root executables, in general).
I think everything belongs to group informix. You should check that
all these are correct before doing anything else. You will need to
know the 'informix' password, in general. The fact that things worked
when run as root means that the user and group exist, but the fact that
things fail almost certainly mean that you've got incorrect permissions.
There are tools for checking permissions in the IIUG software archive
at http://www.iiug.org. One such package is utils_jl (yes, mine).
> I was able to finally build the sysmaster database by logging in as root
> and running onmode -m. This time sysmaster was built successfully and
> now I am able to bring the server online from queiscent mode. However,
> my problems continue as I am unable to connect to server and create a
> new database. Through onmonitor I am able to view Profile, Userthreads,
> and Spaces, however, when I choose Databases, I get the following error
>
> Error writing to network
> Cannot access database catalog TBLspace
>
> I am not sure if onmonitor accesses the sqlhosts and /etc/services but I
> have added the appropriate entries in them as follows. Name of the
> machine as well as informix server is russell.
>
> entry in $INFORMIXDIR/etc/sqlhosts
> russell ontlitcp russell pd1_on> entry in /etc/services
> pd1_on 1543/tcp
I suspect that you've lost a number of SUID and/or SGID bits
on your file permissions.
--
Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net)
Guardian of DBD::Informix v0.95 -- see http://www.perl.com/CPAN
#include <disclaimer.h>