RE: Error in Enterprise Replication
Posted in 2007
Navaid,
You need to load the data in smaller chunks. You are opening a
transaction at the beginning of the insert and then you start inserting
records, these inserts are getting put into the logical logs. You cannot
wrap around the opening of the transaction, "BEGIN WORK".
I would suggest you use dbload to load the data using smaller
transaction sets.
David
________________________________
From: informix-list-bounces@iiug.org
[mailto:informix-list-bounces@iiug.org] On Behalf Of Navaid Arif
Sent: Wednesday, May 16, 2007 8:12 AM
To: admin-tools@iiug.org; informix-list@iiug.org; classics@iiug.org;
ids@iiug.org
Subject: Re: Error in Enterprise Replication
Hi All,
I have increased the number of logical logs by adding 9 more logical
logs of 20MB each. Now I have 20 logical logs. But the problem is that
after performing some table load activity all logs have become 100%
used. At this stage, no application is running even I have restarted the
IDS but previous logs are still showing 100% utilization of logical logs
and no more space is available showing error "LONG TRANSACTION
DETECTED".
I will really appreciate if someone will help me in freeing this logical
logs space.
Test >onstat -l
IBM Informix Dynamic Server Version 10.00.UC5 --
Quiescent -- Up 00:55:25 -- 46240 Kbytes
Physical Logging
Buffer bufused bufsize numpages numwrits pages/io
P-1 6 8 8337 1196 6.97
phybegin physize phypos phyused
%used
8:6931 5000 4627 6
0.12
Logical Logging
Buffer bufused bufsize numrecs numpages numwrits
recs/pages pages/io
L-1 0 8 1326284 29680 4626
44.7 6.4
Subsystem numrecs Log Space used
OLDRSAM 1326282 116667676
SBLOB 1 44
CDR 1 40
address number flags uniqid begin
size used %used
502344b0 1 U-B---- 534 1:763
500 500 100.00
502344f8 2 U-B---- 535 1:1263
500 500 100.00
50234540 3 U-B---- 536 1:1763
500 500 100.00
50234588 4 U-B---- 537 1:2263
500 500 100.00
502345d0 7 U-B---- 538 8:923
500 500 100.00
50234618 5 U-B---- 539 1:2763
500 500 100.00
50234660 6 U-B---- 540 1:3263
500 500 100.00
502346a8 8 U-B---- 541 4:71993
500 500 100.00
502346f0 11 U-B---- 542 4:72993
500 500 100.00
50234738 9 U-B---- 543 4:72493
500 500 100.00
50234780 10 U-B---- 544 8:1431
500 500 100.00
502347c8 12 U-B---- 545 8:1931
5000 5000 100.00
50234810 13 U-B---- 546 8:11931
5000 5000 100.00
50234858 14 U-B---- 547 8:16931
5000 5000 100.00
502348a0 15 U---C-L 548 8:21931
5000 317 6.34
502348e8 16 U-B---- 530 8:26931
5000 5000 100.00
50234930 17 U-B---- 531 6:3
5000 5000 100.00
50234978 18 U-B---- 532 6:5003
5000 5000 100.00
502349c0 19 U-B---- 533 6:10003
5000 5000 100.00
604bbfb0 20 A------ 0 6:15003
5000 0 0.00
20 active, 20 total
Test >
Regards,
Navaid Arif
----- Original Message -----
From: Navaid Arif <mailto:navaid.arif@access.net.pk>
To: admin-tools@iiug.org ; informix-list@iiug.org ;
peoplemix@iiug.org ; classics@iiug.org ; ids@iiug.org
Sent: Wednesday, May 02, 2007 11:36 AM
Subject: Error in Enterprise Replication
Hi All,
I am using IDS 10 UC5 and during testing of Enterprise
Replication facing following problem: Anyone have any idea about it?
SQL: New Run Modify Use-editor
Output Choose Save Info Drop Exit
Modify the current SQL statements using
the SQL editor.
----------------------- dbname@srvtest
-------- Press CTRL-W for Help --------
load from loghisttbl.dmp insert intologhisttbl
458: Long transaction aborted. 12204:RSAM error: Long transaction detected.
847: Error in load file line 5825.
Regards,
Navaid Arif
________________________________
_______________________________________________
Informix-list mailing list
Informix-list@iiug.org
http://www.iiug.org/mailman/listinfo/informix-list