Informix integration with DP
Posted in 2015
Topics: Backup & Restore, Installation, Setup & Upgrades, Storage & Space Management, Platform-Specific Issues
Hello all,
DBs: IDS 11.70.FC8GE
OS: Microsoft Windows Server 2008 R2 with SP2
Media manager: HP DP A.09.00
Backup-type: whole-system backup
We have an environment with onbar integration for HPDP A.09.00.
Backups/restores are working fine and the integration was configured as
following HP's installation guide for this product version.
BUT, on a random basis, not so frequently, when a backup session failed (no
matter the reason), DP shows this backup session as successful/completed,
no matter that the only files backed up for example are only the critical
files, and not a single dbspace or current log o_O
The failing function is part from DP's library - (BSACreateObject)
We've reported this issue to the vendor, but investigation will take some
time.
I am wondering if somebody has seen the same behavior and can give me more
information while waiting?
thanks a lot in advance.
BR,
Lyubo
--047d7bd74f9e7329c7051462ec36
Hello, my friend.
My suggestions for identifying what's going on for DP debugging is:
1) check your Informix server BAR_ACT_LOG file, and see what are the error
code(s), when the situation occurs
It might be happening some kind of "cannot backup because there is already a
backup up running" error, kinda..
2) If the first step did not help you, you can set a debug level (3 or 4) to
your onbar process, and watch for the next time the error happens, and
investigate onbar log files (this time, the debug file configured, instead).
It should log a big stack of system calls, that might help you in case there
is some kind of DP bug.
3) if none of above helps, you should open a PMR in IBM support, for analysis
and support (you might be facing some APAR in your Informix engine - even if I
don't remember one from onbar, for your actual version.
Obs: I would also recommend you not to use "whole system backups", I had some
issues that were solved selecting manually, all of the engine dbspaces,
instead of doind whole system backups. Supposing it is a production box, that
does not have many adds/removes of dbspaces, it should not be a problem for
you.
Hope this helps.
Best regards.
Alexandre Marini
IBM Informix Certified Professional v10 / v11.50 / v11.70 / v12.10
IBM Information Management Informix Technical Professional
IBM Certified Developer - Informix Genero
BRIUG website administrator
Informix independent consultant
> To: ids@iiug.org
> From: lgrigorlu1@gmail.com
> Subject: Informix integration with DP [35003]
> Date: Thu, 23 Apr 2015 07:53:12 -0400
>
> Hello all,
>
> DBs: IDS 11.70.FC8GE
> OS: Microsoft Windows Server 2008 R2 with SP2
> Media manager: HP DP A.09.00
> Backup-type: whole-system backup
>
> We have an environment with onbar integration for HPDP A.09.00.
>
> Backups/restores are working fine and the integration was configured as
> following HP's installation guide for this product version.
>
> BUT, on a random basis, not so frequently, when a backup session failed (no
> matter the reason), DP shows this backup session as successful/completed,
> no matter that the only files backed up for example are only the critical
> files, and not a single dbspace or current log o_O
>
> The failing function is part from DP's library - (BSACreateObject)
>
> We've reported this issue to the vendor, but investigation will take some
> time.
>
> I am wondering if somebody has seen the same behavior and can give me more
> information while waiting?
>
> thanks a lot in advance.
>
> BR,
> Lyubo
>
> --047d7bd74f9e7329c7051462ec36
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
i almost forgot: do not care about the error description shown in DP reports
of schedules. The description is shown in a wrong way. The error code does not
belongs to "onbar return codes table", it is shown via finderr utility, which
is not valid for onbar codes.
The full onbar error codes are in Information Center website.
Regards.
Alexandre Marini
IBM Informix Certified Professional v10 / v11.50 / v11.70 / v12.10
IBM Information Management Informix Technical Professional
IBM Certified Developer - Informix Genero
BRIUG website administrator
Informix independent consultant
From: alexandre@briug.org
To: ids@iiug.org
Subject: RE: Informix integration with DP [35003]
Date: Thu, 23 Apr 2015 09:52:53 -0300
Hello, my friend.
My suggestions for identifying what's going on for DP debugging is:
1) check your Informix server BAR_ACT_LOG file, and see what are the error
code(s), when the situation occurs
It might be happening some kind of "cannot backup because there is already a
backup up running" error, kinda..
2) If the first step did not help you, you can set a debug level (3 or 4) to
your onbar process, and watch for the next time the error happens, and
investigate onbar log files (this time, the debug file configured, instead).
It should log a big stack of system calls, that might help you in case there
is some kind of DP bug.
3) if none of above helps, you should open a PMR in IBM support, for analysis
and support (you might be facing some APAR in your Informix engine - even if I
don't remember one from onbar, for your actual version.
Obs: I would also recommend you not to use "whole system backups", I had some
issues that were solved selecting manually, all of the engine dbspaces,
instead of doind whole system backups. Supposing it is a production box, that
does not have many adds/removes of dbspaces, it should not be a problem for
you.
Hope this helps.
Best regards.
Alexandre Marini
IBM Informix Certified Professional v10 / v11.50 / v11.70 / v12.10
IBM Information Management Informix Technical Professional
IBM Certified Developer - Informix Genero
BRIUG website administrator
Informix independent consultant
> To: ids@iiug.org
> From: lgrigorlu1@gmail.com
> Subject: Informix integration with DP [35003]
> Date: Thu, 23 Apr 2015 07:53:12 -0400
>
> Hello all,
>
> DBs: IDS 11.70.FC8GE
> OS: Microsoft Windows Server 2008 R2 with SP2
> Media manager: HP DP A.09.00
> Backup-type: whole-system backup
>
> We have an environment with onbar integration for HPDP A.09.00.
>
> Backups/restores are working fine and the integration was configured as
> following HP's installation guide for this product version.
>
> BUT, on a random basis, not so frequently, when a backup session failed (no
> matter the reason), DP shows this backup session as successful/completed,
> no matter that the only files backed up for example are only the critical
> files, and not a single dbspace or current log o_O
>
> The failing function is part from DP's library - (BSACreateObject)
>
> We've reported this issue to the vendor, but investigation will take some
> time.
>
> I am wondering if somebody has seen the same behavior and can give me more
> information while waiting?
>
> thanks a lot in advance.
>
> BR,
> Lyubo
>
> --047d7bd74f9e7329c7051462ec36
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
When setting debug for onbar (BAR_DEBUG in the onconfig), it could chew up a
lot of disk depending on the level.
If you'll post your error msgs from the $INFORMIXDIR/bar_act.log (or whatever
log file is capturing onbar activity - $INFORMIXDIR/bar_act.log is the
default) I can reply if I recognize them.
Thanks -
Mark Scranton
The Mark Scranton Group
www.markscranton.com
Thanks everybody for your comments and help!
It turned out that the errors coming from the DP library (BSACreateObject
function) were because somebody removed the file-type flags from the backup
specification related to dbspaces and logs, the ones checked were only for
CF. We've fixed this and backup resumed normally.
Just for reference, here are the bar_debug messages related to these
failures:
2015-04-20 18:01:28 4412 4412 Archive started on rootdbs,
ona0aqifx037p0dbs01, sbspace01, logdbs01, physdbs (Requested Level 0).
2015-04-20 18:48:35 4976 4976 bar_main complete, returning 0 (0x00)
2015-04-22 14:52:34 4412 4412 do_xbsa_error: enter
2015-04-22 14:52:34 4412 4412 do_xbsa_error: input the_error 3 function
BSACreateObject
2015-04-22 14:52:34 4412 4412 XBSA Error: (BSACreateObject) A system
error occurred. Aborting XBSA session.
2015-04-22 14:52:34 4412 4412 do_xbsa_error: return 138 (0x8a)
2015-04-22 14:52:34 4412 4412 barCreateObject: return 3 (0x03)
2015-04-23 17:55 GMT+03:00 MARK SCRANTON <mark@markscranton.com>:
> When setting debug for onbar (BAR_DEBUG in the onconfig), it could chew up
> a
> lot of disk depending on the level.
>
> If you'll post your error msgs from the $INFORMIXDIR/bar_act.log (or
> whatever
> log file is capturing onbar activity - $INFORMIXDIR/bar_act.log is the
> default) I can reply if I recognize them.
>
> Thanks -
> Mark Scranton
> The Mark Scranton Group
> www.markscranton.com
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--001a113de56667f3780514732b59