Re: log_full.sh script exits with code 139
Posted in 1997
I just dealt with this -- In our distribution IUS 9.12UC3 on IRIX 6.4 there is a no_log.sh script in the etc directory, replace the ALARM_PROGRAM entry with the full path to no_log.sh and that should do it. We just made that change, and we have not had a problem in 2 hours! David Buttrick WEB Developer The Sporting News http://www.sportingnews.com See A Different Game. > > I do not follow what "process exited with return code 139 means and > > what implications it can have on our log files. > > Your ALARMPROGRAM is returning a non-zero exit code. The alarm program, > in your case the script /usr/informix/etc/log_full.sh, is executed for > any of several interesting events in the engine one of which is when a > logical log file completes. Your config file specifies the sample log > full event handler script the Informix puts into the onconfig.std as an > example. That script is probably failing or at least returning a code > that looks to the engine like an error condition. > > Null out the ALARMPROGRAM, enter your own script or executable, or fix > the log_full.sh script. > > Art S. Kagel