onpload cannot validate logging state of target database
Posted in 2005
I just came home after spending several hours in a migration activity
that failed completely.
Basically, the problem was that "onpladm run job" went silent for a
minute while trying to connect to the server and then comes back with
the error message "onpload cannot validate logging state of target
database".
The activities had been tested several times before tonight on
different machines with the same software setup: IDS 9.40.FC4 on HP-UX
11.11. More tests were performed on different machines with success.
The only place where onpladm failed to connect was on the production
cluster.
The basic test case that we ended up using was:
$ onpladm create project unload
$ onpladm create job test1 -p unload -fu -d test1.out -D database_name
-t table_name
$ onpladm run job test1 -p unload -fu
This sequence ran fine on all machines except on any of the four
servers in the production cluster.
By tracing communication and system calls we were able to determine
that onpladm succeeded in connecting to onpload database and issue a
number of SQL queries. Finally, it ends up performing the same query
against the table "session" repeatedly until it gives up. The system
calls made between these queries were only timer related.
The cluster is using ServiceGuard packages with virtual IP addresses,
but we had the exact same behaviour on an IDS instance using "real" IP
addresses.
online.log did not mention anything.
Anyone have any ideas on what might be the problem or where to look for
more information? I've been thinking that maybe there's some problem
regarding use of shared memory - this cluster is running multiple IDS
instances on the same machine and I thought maybe onpload isn't able to
get a hold of enough shared memory?
We will create a completely new and minimal IDS instance in the
production cluster to experiment on tomorrow and we will probably also
log a support case on this - however, any ideas are still welcome
because we need to solve this pretty quickly (as usual :oP).
thanks for listening.
__________________________________
Do you Yahoo!?
Yahoo! Small Business - Try our new resources site!
http://smallbusiness.yahoo.com/resources/
sending to informix-list