SQL -406 Memory allocation failed.
Posted in 2009
Topics: Backup & Restore, Platform-Specific Issues
We've recently started receiving this error during restore. It was working fine in the past. IDS: BM Informix Dynamic Server Version 9.40.HC6X1 -- On-Line -- Up 108 days 15:01:51 -- 526420 Kbytes OS: HP-UX B.11.11 U 9000/800 The restore abended with a similar error as during the Disaster test: 2009-10-13 12:00:44 18439 18436 Out of memory 2009-10-13 12:00:44 18439 18436 An attempt to add 534505 to a linked list failed with error 7 2009-10-13 12:00:44 18439 18436 SQL -406 Memory allocation failed. 2009-10-13 12:00:44 18439 18436 /opt/informix/ifx940.hc6x1/bin/onbar_d complete, returning 158 (0x9e) Thanks, ******************************************************************* Ernie Knox IT Database Administrator Specialist Sears Holdings 3333 Beverly Rd., B4-266A Hoffman Estates, IL. 60179 Office: (847) 286-5735 Email: Ernest.Knox@searshc.com Blackberry: 2244650553@messaging.sprintpcs.com <mailto:2244650553@messaging.sprintpcs.com> Page via Skytel: 2244650553@sprint.skytel.com <mailto:2244650553@sprint.skytel.com> Informix or MySQL Primary: 9110210@skytel.com <mailto:9110210@skytel.com> Informix or MySQL Secondary: 7276872@skytel.com <mailto:7276872@skytel.com> " Yes we can make a Change! " " It's always a great day to watch Sports - GO LIONS, TIGERS, and BEARS! " " Lets not forget - GO Pistons and Red Wings! " GSU *******************************************************************
-406 Memory allocation failed. Something in the current statement required the allocation of memory for data storage, but the memory was not available. Several things can cause this error. For example, your application has a memory leak, you are asking for more resources than the system is configured to allow, or a problem with UNIX requires that you reboot the system. On a client PC, if the INFORMIXDIR environment variable or some GLS file is missing, a connection attempt fails with this error message. Rollback the current transaction. Look for ways to make this statement simpler or move less data. On UNIX, talk with the system administrator to solve memory problems or to look for ways to make the operating system give this program more virtual memory in which to run. On Windows, exit to the operating-system command line, free some disk space, and resubmit your program. On a client PC, make sure that the INFORMIXDIR environment variable is set and that all GLS files are available. Also, if its working before, it should work fine. Also, please check if there are informix processes running "ipcs -m|grep -n informix". kill the process and start to restore again.