Virtual Memory
Posted in 2000
Topics: General Discussion
We are running Informix 7.3 on HPux 11 On a system with 6Gb available memory, I am trying to increase the SHMVIRTSIZE. It is currently set to 2000000 kb ( 2 Gb ). Initially I tried increasing by 500000 kb this resulted in informix failing to initialise with error "size of resident + virtual segments 943613032 + 4294705152 > 5120000000 total allowed by configuration parameter SHMTOTAL" As can be seen SHMTOTAL is set to 5Gb. My question is why is informix trying to allocate 4 Gb of SHMVIRTSIZE when all I am asking for is 2.5 Gb. Note, I have tried various settings of SHMVIRTSIZE between 2 Gb & 2.5Gb and Informix seems to want to allocate 4Gb for any value of SHMVIRTSIZE over 2096000 kb. Cheers, Howard
In article <85nb3b$5e2$1@gxsn.com>,
"Howard Jones" <howard.jones@icl.com> wrote:
> We are running Informix 7.3 on HPux 11
>
> On a system with 6Gb available memory, I am trying to increase the
> SHMVIRTSIZE. It is currently set to 2000000 kb ( 2 Gb ). Initially I
tried
> increasing by 500000 kb this resulted in informix failing to
initialise with
> error
>
> "size of resident + virtual segments 943613032 + 4294705152 >
5120000000
> total allowed by configuration parameter SHMTOTAL"
>
> As can be seen SHMTOTAL is set to 5Gb.
> My question is why is informix trying to allocate 4 Gb of SHMVIRTSIZE
when
> all I am asking for is 2.5 Gb.
>
> Note, I have tried various settings of SHMVIRTSIZE between 2 Gb &
2.5Gb
> and Informix seems to want to allocate 4Gb for any value of
SHMVIRTSIZE over> 2096000 kb.
>
> Cheers,
>
> Howard
>
>
Check with HP for a patch. We had a similar problem on a project I was
on several months ago, and it was caused by some >2GB shared memory
problem on HP. They were working on a patch but I left the contract
before that problem was resolved, so I can't help more than that.
--
# unrm /
ksh: unrm: not found
# man cpio
Sent via Deja.com http://www.deja.com/
Before you buy.
In article <85nudr$cep$1@nnrp1.deja.com>, <mars1972@my-deja.com> wrote:
>In article <85nb3b$5e2$1@gxsn.com>,
> "Howard Jones" <howard.jones@icl.com> wrote:
>> We are running Informix 7.3 on HPux 11
>> On a system with 6Gb available memory, I am trying to increase the
>> SHMVIRTSIZE. It is currently set to 2000000 kb ( 2 Gb ). Initially I
>tried
>> increasing by 500000 kb this resulted in informix failing to
>initialise with
>> error
>> "size of resident + virtual segments 943613032 + 4294705152 >
>5120000000
>> total allowed by configuration parameter SHMTOTAL"
>> As can be seen SHMTOTAL is set to 5Gb.
>> My question is why is informix trying to allocate 4 Gb of SHMVIRTSIZE
>when
>> all I am asking for is 2.5 Gb.
>> Note, I have tried various settings of SHMVIRTSIZE between 2 Gb &
>2.5Gb
>> and Informix seems to want to allocate 4Gb for any value of
>SHMVIRTSIZE over>> 2096000 kb.
>Check with HP for a patch. We had a similar problem on a project I was
>on several months ago, and it was caused by some >2GB shared memory
>problem on HP. They were working on a patch but I left the contract
>before that problem was resolved, so I can't help more than that.
Can't comment on HP-UX 11.0 specifically, but here's a couple of things.
When you launch Informix with a 2-gig virtual segment, what segment
sizes are reported in online.log? If they add up to close to 4.5 GB
before your change, then you'll have to fiddle with the kernel parms.
I've also found that with Informix 7.31 and large shared memory
allocations (resident or virtual) on HP-UX 10.20, the line between
segments is somewhat blurred (the resident segment is smaller than the
cache size I requested, but it shows up in what onstat reports as the
virtual segment).
Jim
>--
># unrm /
>ksh: unrm: not found
># man cpio
man: not found
--
W. Jim Jordan, Nortel Networks, Stop 29CA3A08 | +1 613 763 1568
PO Box 3511 Stn C, Ottawa, ON K1Y 4H7 Canada | wjjordan@nortelnetworks.com
Opinions expressed are not necessarily those of Nortel Networks.
Inbound spam filtering is in place. Don't send what I won't see.