Hello,
I have an app running a "alter fragment on mytable attach ..."
statement. Occasionally, this statement is launched while
log_full.sh is running, so I get a SQL error -242, the corresponding
ISAM error code is 106).
I guess the reason is that "onbar -l" in ~informix/etc/log_full.sh
locked up the database. Am I right ?
I think IDS should support selecting waiting for a locked resource
(table or index , etc) or returning an error immediately if the
resource is locked, at SQL statement level. But I do not how to
achieve this, is there anyone can give me a suggestion?
Harry