connecting to Informix results error -908
Posted in 2006
Topics: General Discussion
Hi ! I have Informix Dynamic Derver 9.4 and Client-SDK 2.90 running on Windows XP. The problem is that trying to connect the client to the data base results : error -908. Informix Error Messages tells about this error: "Attempt to connect to database server (servername) failed." Furthemore I've found this error indicates: "Verify the listening port number defined on the server matches the client. " Please, could anybody help me? Thanx
Looks like a setup issue. Was this working earlier? Is dbaccess able
to connect? What client type of application are you talking about? If
it is ODBC, then the setup is different from what is mentioned below.
Check your setnet32 settings. setnet32 Environment tab should have the
correct INFORMIXDIR setting. Also, the server/host tabs need to be
updated with the correct information. The server name needs to match
the DBSERVERNAME in the ONCONFIG file.
VG.
ch wrote:
> Hi !
> I have Informix Dynamic Derver 9.4 and Client-SDK 2.90 running on
> Windows XP.
> The problem is that trying to connect the client to the data base
> results : error -908.
> Informix Error Messages tells about this error: "Attempt to connect to
> database server (servername) failed."
>
> Furthemore I've found this error indicates: "Verify the listening port
> number defined on the server matches the client. "
>
> Please, could anybody help me?
>
> Thanx
ch wrote: > Hi ! > I have Informix Dynamic Derver 9.4 and Client-SDK 2.90 running on > Windows XP. > The problem is that trying to connect the client to the data base > results : error -908. > Informix Error Messages tells about this error: "Attempt to connect to > database server (servername) failed." > > Furthemore I've found this error indicates: "Verify the listening port > number defined on the server matches the client. " > > Please, could anybody help me? > > Thanx > Use dbping and to test/correct the setting, once you've got that working transfer the values to setnet32 and will just work Cheers Paul Paul Watson Oninit Ltd Tel : +44 1414161772 Cell : +44 7818 003457 Web : www.oninit.com
I have just installed it, and I think the data base is running, but I'm not sure. I have checked the INFORMIXDIR and the DBSERVERNAME settings. But it doesn't work :-(
I can't do a dbping because it's a port.