Re: Bad Primary Chunk
Posted in 1998
art_pong@hotmail.com offerred: +Unfortunately the disk with my Informix database went bad. It is an older +copy of Informix (V5?) running on a SunOS 4.1.4 machine with the data stored +on a raw partition (not mirrored). My last backup is a little out of date. +I was wondering if it's possible to recover the data. I used 'dd' to try +and transfer data from the raw partition to another disk, which seemed to +work (it had several retryable errors, but it went through). Informix still +reports an error on the new raw partition. Couple of thoughts on this: If the contents of the original partition is "bad", i.e. Informix will not use it, then the odds that a dd taken from that "bad" partition containing reliable info from Informix's perspective is slim indeed. A backup of a bad partition must be considered bad itself. Even if that were not the case, it is not as simple as dding the data to a different partition and restarting online. For one thing, the system reserved pages contain the config info of your system, including the chunk pathname. If you have dd'ed it to a new partition, the names will not match, and the database will not come up. You could get around this using links to make the new partition have the same name as the old one, though it assumes you have completely removed the original disk. Additional info that would be useful: how did your disk go "bad"? Head crash? Controller failure? Exactly what error did Informix report, and what error is it reporting now against the new partition? Pertinant message log entries would also be useful. Dave ** Dave Kosenko <davek@summitdata.com> ** Director of Training Services (732) 469-4070 ** Summit Data Group (an Informix Authorized Education Center) ** Find my advice useful? Let me teach you everything I know about ** Informix. Sign up for OFFICIAL Informix training at SDG. ** For details, see http://www.summitdata.com/training