INFORMIX-OnLine Must ABORT - Critical media
Posted in 2012
Topics: Error Codes & Troubleshooting, Logging & Checkpoints
Hi, we got a strange problem with an 9.21.UC2. The wasnt shut down proberly, and now, we cant start the engine again. Online.log sais: 17:58:37 Informix Dynamic Server 2000 Initialized -- Shared Memory Initialized. 17:58:37 Physical Recovery Started. 17:58:37 Physical Recovery Complete: 384 Pages Restored. 17:58:37 Logical Recovery Started. 17:58:37 10 recovery worker threads will be started. 17:58:37 Rollforward of log record failed. iserrno = 0 17:58:37 Log Record: log = 9980, pos = 2e230c, type = OLDRSAM:CHFREE(52), trans = 94 17:58:37 Rollforward of log record failed. iserrno = 0 17:58:37 Log Record: log = 9980, pos = 2e230c, type = OLDRSAM:CHFREE(52), trans = 94 17:58:37 Rollforward of log record failed. iserrno = 0 17:58:37 Log Record: log = 9980, pos = 2eb6d8, type = OLDRSAM:CHFREE(52), trans = 94 17:58:37 Rollforward of log record failed. iserrno = 0 17:58:37 Log Record: log = 9980, pos = 2eb6d8, type = OLDRSAM:CHFREE(52), trans = 94 17:58:37 Rollforward of log record failed. iserrno = 0 17:58:37 Log Record: log = 9980, pos = 2eb6fc, type = OLDRSAM:CHFREE(52), trans = 94 17:58:37 Rollforward of log record failed. iserrno = 0 17:58:37 Log Record: log = 9980, pos = 2eb6fc, type = OLDRSAM:CHFREE(52), trans = 94 17:58:37 Rollforward of log record failed. iserrno = 0 17:58:37 Log Record: log = 9980, pos = 448170, type = OLDRSAM:CHALLOC(51), tran s = 14 17:58:38 Assert Failed: INFORMIX-OnLine Must ABORT Critical media failure. 17:58:38 Informix Dynamic Server 2000 Version 9.21.UC2 17:58:38 Who: Session(11, informix@ux10118, 0, -1982546488) Thread(29, xchg_2.0, 89d1dab0, 1) File: rsmirror.c Line: 1746 17:58:38 stack trace for pid 9092 written to /tmp/af.405113d 17:58:38 See Also: /tmp/af.405113d, shmem.405113d.0 17:58:55 rsmirror.c, line 1746, thread 29, proc id 9092, INFORMIX-OnLine Must ABORT Critical media failure.. 17:58:55 PANIC: Attempting to bring system down How can i get rid of those physical log. I dont care about a consistent DBMS, just need the Server online.
It looks like there is a partial log record that was written at the end of the logical logs when the machine crashed and the contents are not sufficient for the engine to properly recover during fast recovery. If and ONLY if you have IBM support (yes 9.21 has been out-of-support for several years) IBM can connect to your system and truncate the last logical log file and permit the server to start up. You can try calling them and see if they will help, but the chances are low. Art Art S. Kagel Advanced DataTools (www.advancedatatools.com) Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Advanced DataTools, the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Thu, Jan 12, 2012 at 12:05 PM, DJIHANGIROF MATTHIAS <steellynx@gmx.de>wrote: > Hi, > > we got a strange problem with an 9.21.UC2. > > The wasnt shut down proberly, and now, we cant start the engine again. > > Online.log sais: > > 17:58:37 Informix Dynamic Server 2000 Initialized -- Shared Memory > Initialized. > > 17:58:37 Physical Recovery Started. > 17:58:37 Physical Recovery Complete: 384 Pages Restored. > > 17:58:37 Logical Recovery Started. > 17:58:37 10 recovery worker threads will be started. > 17:58:37 Rollforward of log record failed. iserrno = 0 > 17:58:37 Log Record: log = 9980, pos = 2e230c, type = OLDRSAM:CHFREE(52), > trans = 94 > 17:58:37 Rollforward of log record failed. iserrno = 0 > 17:58:37 Log Record: log = 9980, pos = 2e230c, type = OLDRSAM:CHFREE(52), > trans = 94 > 17:58:37 Rollforward of log record failed. iserrno = 0 > 17:58:37 Log Record: log = 9980, pos = 2eb6d8, type = OLDRSAM:CHFREE(52), > trans = 94 > 17:58:37 Rollforward of log record failed. iserrno = 0 > 17:58:37 Log Record: log = 9980, pos = 2eb6d8, type = OLDRSAM:CHFREE(52), > trans = 94 > 17:58:37 Rollforward of log record failed. iserrno = 0 > 17:58:37 Log Record: log = 9980, pos = 2eb6fc, type = OLDRSAM:CHFREE(52), > trans = 94 > 17:58:37 Rollforward of log record failed. iserrno = 0 > 17:58:37 Log Record: log = 9980, pos = 2eb6fc, type = OLDRSAM:CHFREE(52), > trans = 94 > 17:58:37 Rollforward of log record failed. iserrno = 0 > 17:58:37 Log Record: log = 9980, pos = 448170, type = OLDRSAM:CHALLOC(51), > tran s = 14 > 17:58:38 Assert Failed: INFORMIX-OnLine Must ABORT > > Critical media failure. > 17:58:38 Informix Dynamic Server 2000 Version 9.21.UC2 > 17:58:38 Who: Session(11, informix@ux10118, 0, -1982546488) > > Thread(29, xchg_2.0, 89d1dab0, 1) > > File: rsmirror.c Line: 1746 > 17:58:38 stack trace for pid 9092 written to /tmp/af.405113d > 17:58:38 See Also: /tmp/af.405113d, shmem.405113d.0 > 17:58:55 rsmirror.c, line 1746, thread 29, proc id 9092, INFORMIX-OnLine > Must > ABORT > > Critical media failure.. > 17:58:55 PANIC: Attempting to bring system down > > How can i get rid of those physical log. I dont care about a consistent > DBMS, > just need the Server online. > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --e89a8f3bb08d58315504b657f692