Re: VERY URGENT: why this behaviour?
Posted in 2000
Flavio Gattari wrote:
>
> whe submit the following sql statement to an IDS2000 (release 9.21) server:
>
> select a.id_cen_originatore,
> a.cd_tipo_messaggio,
> a.dt_validita,
> a.id_spe_trasmn,
> a.id,
> b.tempo_permanenza
> FROM Gruppo_Report a,
> Tipo_Messaggio b
> WHERE a.cd_tipo_messaggio=b.cd_tipo_messaggio
> and a.dt_inserimento+b.tempo_permanenza units hour<'2000-08-29 12:00:00'>
> it returns the following error:
> --1268: invalid datetime or interval qualifier
Have you spoken to Informix Tech Support? There are known bugs to do
with DATETIMES in version 9.20, and based on the fact that I recently
logged one of them, they are probably still in version 9.21. :-(
Cheers,
--
Mark.
+----------------------------------------------------------+-----------+
| Mark D. Stock mailto:mdstock@mydas.freeserve.co.uk |//////// /|
| http://www.informix.com http://www.informixhandbook.com |///// / //|
| http://www.iiug.org +-----------------------------------+//// / ///|
| |This email will self-destruct in |/// / ////|
| |10 sec. If you received this email |// / /////|
| |in error, sorry about the mess. |/ ////////|
+----------------------+-----------------------------------+-----------+