Re: multi-residency vs. single instance, multi-database
Posted in 1998
Good question. Indeed, this topic is not explicitly discussed in
detail in the docs or in training. Your Informix trainer is often
an expert in multiple instances, though, as for most classes there
is one instance per student on a single machine.
You will commonly run into two limitations: o/s semaphores and
total memory. In either case, the "oninit" command will fail with
an error message in the usual places (message log, on screen,
and the system console.) You may have to clean up leftover memory
segments with the "ipcrm" command (in Unix) on an initialization
failure.
There is a limit on the range of the SERVERNUM parameter that provides
an Informix-specific upper bound on the number of instances.
The release notes (cheers! for reading them) have a list of the
parameters that worked in testing. They are a starting point
for you to configure the o/s and the instance. Your application
may run well with less than the specified values, or may
require much larger parameters. For this reason it is really
impossible to give a much better generic answer than "it depends."
One way that Informix has tried to aid in this kind of planning
is by using static structures rather than dynamic ones. (LOCKS,
for example.) As I mentioned once before, this is changing. When
it does change, your instance's memory requirements will vary
with the actions of the users even more than they currently do,
making this kind of planning even harder. Under the Universal
Data Option you may log BLOB data, which may increase the size
of the task by another order of magnitude.
You can ask Informix consulting to assist you with the task of
determining how your application's needs impact memory, or you
can examine it yourself through iterative incremental examination.
Onstat and your o/s memory tools will give you a pretty good
picture.
Good luck,
Clem
At 03:04 PM 05-11-98 -0500, phuoc ho wrote:
>I have checked both the new and old System Administration: Informix Dynamic
>Server training manuals. I have also scanned through the online document CD.
>Nothing in there to guide me through the configuration of multiple instances.
>The kernel parameters at the beginning of the release notes show recommended
>kernel values for a single instance. Will these values work for multiple
>instances?
>
>I have also taken the Online Tuning course. Not much was mentioned in it
>either. I guess that multiple-instance is the exception not the norm.
>Therefore, the shortage of information.
>
>I have no problems setting up multiple instances. Making sure that they run
>without "tripping" over each other is my problem.
>
>Phuoc Ho
_______________________________________________________________
Clem Akins (aka clem@informix.com) Menlo Park x5937
Customer Course Development Informix Software, Inc
Last seen: 1100cc 2-wheel trail riding, Hollister, California