Re: Can't attach to shared memory Problem.
Posted in 1994
}From: abethelm@ccssrv1.corp.harris.com (Ancil Abethelmy) }Subject: Can't attach to shared memory Problem. }Date: Wed, 6 Jul 1994 13:47:27 GMT }X-Informix-List-Id: <news.7485> } }I have an NCR box running SCO Unix 3.2 and }ONLINE_5.0, ESQLC_5.0, STAR_5.0, and ISQL_4.1 } }The problem is that I just recently added the I-STAR5.0 then }configured a second instance of online. when I start up either/both }instance(s) I can't attach to shared memory I get these }error messages: 529: Cannot attach to shared memory. }and: 116: ISAM error: cannot allocate memory. } }I have looked at a few parameters through tbmonitor and found that both }instances use the same base address for SHMBASE: 0x80400000 } }This seems to say to me that both instances are trying to use the same block }of shared memory (I don't think that will work). Using the same SHMBASE is unlikely to be the problem. Much more likely, you have not changed the server numbers (SERVERNUM in tbconfig), so they are both using the same shared memory IDs, and the one which tries to start up second says that its shared memory segment already exists. Check the SERVERNUM and DBSERVERNAME parameters. If they aren't the same, then we need to rethink... Yours, Jonathan Leffler (johnl@informix.com) #include <disclaimer.h>