Re: Error restarting server
Posted in 1997
At a guess, I'd say your shared memory segments were not cleared up
properly. Login as root, and type
ipcs
If you see any shared memory segments there, you will need to remove
them.
WARNING!!!! This only applies if you are not running any other shared
memory applications. There is a formula for calculating the base
address of the OnLine shared memory somewhere in the manuals. This
will give you the starting point for the segments you need to remove
if there are other shared memory apps running.
Good luck!
On 13 Nov 97 at 15:50, Ken Rothman wrote:
} Informix Novice Question:
}
} I had to shut down my server (7.21 on Solaris) yesterday,
} which I did with onmode -k. It seemed to shut down cleanly.
}
} However, when I now attempt to restart it using oninit, I'm getting
} the following error:
}
} oninit: Fatal error in initializing ASF with 'ASF_INIT_DATA' flags;
} asfcode = '-25580'.
}
} and the log shows the following:
}
} Thu Nov 13 10:24:49 1997
}
} 10:24:49 Event alarms enabled. ALARMPROG =
} '/home1/informix/log_full.sh' 10:24:52 DR: DRAUTO is 0 (Off)
} 10:24:52 shmget: [EEXIST][17]: key 52574805: shared memory already
} exists 10:24:52 (2) shm creation of shmem segment failed
}
}
} What can I do???
}
} --Ken
} krothman@exapps.com
} krothman@cs.brandeis.edu
}
--
Ciao,
Billy
Swanning around in: Johannesburg, Sarf Efrica.
Get the Informix FAQs of life at http://www.iiug.org/techinfo/faq/faq_top.html
Need to get some drivel into your life? http://www.west.co.za/tasteless/