Re: error in OnLine initialization(can't create 'sysmaster'
Posted in 1999
I solved this problem by changing my DBSERVERNAME to my INFORMIXSERVERNAME.
I don't know if it is necessary that these two PARAMETERS have same values?and
if we can have different names for our DBSERVERNAME and INFORMIXSERVERNAME and
if yes what changes should be done?
thanks
--babak
> From bayati@tmcso.com Mon Aug 2 19:40:07 1999
> Date: Mon, 2 Aug 1999 18:04:03 +0430
> From: bayati@tmcso.com (Babak Bayati)
> To: informix-list@iiug.org
> Subject: error in OnLine initialization(can't create 'sysmaster'
> X-MDaemon-Deliver-To: bayati@tmcso.com
> X-Return-Path: owner-informix-list@iiug.org
>
> Hi,
> plattform:
> Solaris2.5,IDS7.23UC1
> After initializing OnLine,this is what is written in "online.log":
>
> 17:32:42 Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
> 17:32:43 DR: DRAUTO is 0 (Off)
> 17:32:44 INFORMIX-OnLine Initialized -- Complete Disk Initialized.
> 17:32:44 Checkpoint Completed: duration was 0 seconds.
> 17:32:44 Dataskip is now OFF for all dbspaces
> 17:32:44 On-Line Mode
> 17:32:44 Building 'sysmaster' database ...
> 17:32:46 Error building 'sysmaster' database.
> 17:32:46 See '/tmp/buildsmi.508'.>
> this is a part of '/tmp/buildsmi.508' file:
>
> This file is the output of the dbaccess command in the shell script,
> $INFORMIXDIR/etc/buildsmi. This script is run when Informix OnLine
> DSA is first initialized. It builds the database and tables
> which support the System Monitoring Interface. If you were directed
> to see this file, a problem probably occurred while building the
> database and/or its tables and views. See below for more information
> regarding any problems.
>
> Problems may have occurred if OnLine was shutdown after initialization
> but before the entire database was created. If this was the case,
> login as 'informix', rerun 'oninit', and wait for the message
>
> "'sysmaster' database created successfully"
>
> to appear in the OnLine message log before shutting down. Once it is
> created successfully, it should never need to be recreated.
>
>
> 25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.
> Error in line 14> Near character position 1
> ...
>
> These error has appeared recently and previousely I didn't have such error and
> I had many databases on my instance.
> I've set all necessary env. vars and add appropriate line to 'sqlhosts' file.
> has any one had such a problem before?
> any idea would be greately appreciated
>
> regards
> --babak
>
>
>
>
>
>