Re: IDS 7.3 Restore to new server
Posted in 2003
----- Original Message -----
To: greg.lintott@police.govt.nz
At: 3/28 9:13
Try to bring up the engine manually with the -v flag (oninit -v) to see the
startup step by step and see where it fails. Things to look at:
- Did you change the DBSERVERNAME in the ONCONFIG file?
- permissions on the newly touched chunk files must be 660 owner informix group
informix.
- Do user informix and group informix exist on the new machine?
- Make sure the ports are listed in /etc/services?
- Check the release notes for OS patches and kernel config parameters that need
to be made (or compare the configuration to the working server which is better
yet).
Anyway if all this checks out post the oninit -v output and maybe someone will
recognize the symptom.
Art S. Kagel
----- Original Message -----
From: Greg Lintott <greg.lintott@police.govt.nz>
At: 3/27 18:18
> I am an experienced DBA (not Informix) who is settng up a new system for a
> client.
>
> What I need to do is backup a database on one Sun server and restore it on
> another sun server. I have not been able to get this to work. The process I
have
> used was to copy the "ONCONFIG' file across tothe new server, update the
> SQLHOSTS file and touch the files for the database chunks to create them as
> empty files.
>
> I then did a ontape (ontape -b -L0) backup to disk, copied this file across
to
> the new server and issued a ontape -r command. This returns the following
output
>
> ontape -r>
> Please mount tape 1 on /data1/informixdata/backups/dbatest/test_backup.dmp
and
> press Return to continue ...
>
> Archive Tape Information
>
> Tape type: Archive Backup Tape
> Online version: Informix Dynamic Server Version 7.31.UD4
> Archive date: Tue Mar 25 16:06:36 2003
> User id: informix
> Terminal id: /dev/pts/4
> Archive level: 0
> Tape device: /data1/informixdata/backups/dbatest/test_backup.dmp
> Tape blocksize (in k): 65536
> Tape size (in k): 10000000
> Tape number in series: 1
>
> Spaces to restore:1 [dbatestrootdb ]
> 2 [dbatestlogsp ]
> 3 [dbatestdatasp ]
>
> Archive Information
>
> Informix Dynamic Server Copyright(C) 1986-1998 Informix Software, Inc.
> Initialization Time 09/11/2002 15:06:01
> System Page Size 2048
> Version 6
> Archive CheckPoint Time 03/25/2003 16:06:41
>
> Dbspaces
> number flags fchunk nchunks flags owner name
> 1 1 1 1 N informix dbatestrootdb
> 2 1 2 1 N informix dbatestlogsp
> 3 1 3 1 N informix dbatestdatasp
>
> Continue restore? (y/n)y
> Do you want to back up the logs? (y/n)n
> Physical restore failed - could not fork server connection
>
> Program over.
> ==========================================
>
> Not knowing a lot about informix I;m not sure if this is a genuine error or
is
> caused by the method I am using. Any help/suggestions would be much
appreciated.