Re: bcheck -s *.idx produces "Cannot link .idx and .IDX" files
Posted in 1995
Spokey the Wheeler <spokey@haunted.demon.co.uk> wrote: >In article <42rb88$g9h@news.wwa.com> john@miso.wwa.com "pinoy_ako" writes: > >> Hi, >> We use SE/R4GL 6.00 on NCR SVR4. One of our programs just suddenly >> stopped working with an error saying "Table (tablename) does not >> exist". I thought the indices where corrupted so I ran >> >> bcheck -s *.idx >> >> in the $DBPATH/[database name].dbs directory. Then it showed me >> the error in the subject. Can anyone tell me why the error was >> generated? And what do I do with the .IDX files. Pls. email or >> post. Thanks! > >What it *sounds* like is that your system catalogs might be corrupted or >that your systables might have an explicit path name which is no longer >correct. Have you moved tables around on the disk or ALTERed TABLE or >restored backups or anything similar? Check your systables and sysindexes >for the table in question. What it _really_ sounds like is another case of "Spokey likes to see himself post. syndrome" The only thing more annoying than someone who posts a response to every article he sees, without reading the followups that are already there, just to see his response posted, - is to see that person post incorrect statements. In one of your many posts today, you state ILOGIN must work before anything else ODBC will. That is totally false. In the above statement, the cannot link message occurs when the .IDX file already exists. In the case where a user wants to run two reports from one ace file, there's nothing crazy about it at all. It DOES make sense to select all of the data once and run many reports from that selected data. You can do it in 4gl but not in .ace. If you're posting just to see your posts appear, try alt.test