SDS_ENABLE is not set error after server restart
Posted in 2015
Topics: High Availability & Replication, Backup & Restore, Storage & Space Management, Server Administration, Security, Permissions & Auditing, Versions, Editions & End-of-Life
Hi all,
Informix 11.10
We are moving to new servers and while I have time I wanted to set up an HDR
pair to test failover back and forth before I put these into production.
From our existing primary, I did a level 0 dump over the wire to the new
server.
ontape -s -L 0 -F -t STDIO | ssh 192.168.100.229 ".
/etc/profile.d/cargotel.sh; ontape -r -t STDIO"
Then I brought the server up as a standalone with
onmode -m
That succeeded.
I then shut the server down with
onmode -ky
Tried to bring it up with
oninit
which fails with this error:
[informix@746286-ORDDBI1 ~]$ Can not initialize SDS -
SDS_ENABLE is not set, but the rootchunk indicates a shared disk environment
The online.log has the following:
10:59:35 IBM Informix Dynamic Server Stopped.
10:59:53 IBM Informix Dynamic Server Started.
10:59:53 Segment locked: addr=0x44000000, size=114050392064
10:59:53 Segment locked: addr=0x1ad1eee000, size=774144000
Mon Dec 21 10:59:55 2015
10:59:55 pid 13445: can't get real path of
10:59:55 pid 13445: scan_eh_frame(): bad CIE reference
11:00:05 Event alarms enabled. ALARMPROG =
'/opt/IBM/informix/etc/alarmprogram.sh'
11:00:05 Booting Language <c> from module <>
11:00:05 Loading Module <CNULL>
11:00:05 Booting Language <builtin> from module <>
11:00:05 Loading Module <BUILTINNULL>
11:00:13 DR: DRAUTO is 0 (Off)
11:00:13 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
11:00:13 Event notification facility epoll enabled.
11:00:14 IBM Informix Dynamic Server Version 11.10.FC2 Software Serial Number
AAA#B000000
11:00:18 Can not initialize SDS -
SDS_ENABLE is not set, but the rootchunk indicates a shared disk environment
11:00:18 IBM Informix Dynamic Server Stopped.
11:00:18 mt_shm_remove: WARNING: may not have removed all/correct segments
Our production server does not have SDS_ENABLE set in it's onconfig.
I'm told we have had this problem in the past and that it is because we are
trying to bring this up as an HDR primary and the workaround we used before
was to bring it up as an HDR secondary without connecting it to the primary.
That sort of makes sense but I don't know how to do that, or indeed if that's
the proper solution.
Thanks you,
Jeff Ross
Original post:
Hi all,
Informix 11.10
We are moving to new servers and while I have time I wanted to set up an HDR
pair to test failover back and forth before I put these into production.
From our existing primary, I did a level 0 dump over the wire to the new
server.
ontape -s -L 0 -F -t STDIO | ssh 192.168.100.229 ".
/etc/profile.d/cargotel.sh; ontape -r -t STDIO"
Then I brought the server up as a standalone with
onmode -m
That succeeded.
I then shut the server down with
onmode -ky
Tried to bring it up with
oninit
which fails with this error:
[informix@746286-ORDDBI1 ~]$ Can not initialize SDS -
SDS_ENABLE is not set, but the rootchunk indicates a shared disk environment
< ... stuff removed ...>
11:00:18 Can not initialize SDS -
SDS_ENABLE is not set, but the rootchunk indicates a shared disk environment
11:00:18 IBM Informix Dynamic Server Stopped.
11:00:18 mt_shm_remove: WARNING: may not have removed all/correct segments
Our production server does not have SDS_ENABLE set in it's onconfig.
I'm told we have had this problem in the past and that it is because we are
trying to bring this up as an HDR primary and the workaround we used before
was to bring it up as an HDR secondary without connecting it to the primary.
That sort of makes sense but I don't know how to do that, or indeed if that's
the proper solution.
Thanks you,
Jeff Ross
Response:
I'm curious what output (if any) do you get from onstat -g sds verbose on the
production machine you took the archive from? Also, what output do you get
from oncheck -pr output from that instance, only interested in the output for
"Validating PAGE_PZERO"...so that output would look something like this:
Validating IBM Informix Dynamic Server reserved pages
Validating PAGE_PZERO...
Identity IBM Informix Dynamic Ser
ver Copyright 2001, 2015
IBM Corporation
Database system state 0
Database system flags 0x9
64-bit server
BigChunk page flags are not in use
Page Size 2048 (b)
Date/Time created 12/04/2015 10:45:27
Version number of creator 28
Last modified time stamp 0
UID of rootdbs creator 200
Index Page Logging ON since 12/04/2015 10:45:27
HA Disk Owner <null>
Validating PAGE_CONFIG...
The output would continue on, but I'm only interested in the stuff between the
PAGE_PZERO and the PAGE_CONFIG. Particularly the "HA Disk Owner" field.
Jacques Renaut
IBM Informix Advanced Support
APD Team
Hi and thanks for the follow-up!
Here are the results you asked for:
onstat -g sds verbose
IBM Informix Dynamic Server Version 11.10.FC2 -- On-Line (Prim) -- Up 151 days
19:08:06 -- 116497336 Kbytes
Number of SDS servers:0
Updater node alias name :chisec
oncheck -pr
Validating IBM Informix Dynamic Server reserved pages
Validating PAGE_PZERO...
Identity IBM Informix Dynamic Ser
ver Copyright(C) 1986-20
07 IBM Informix Softwar
Database system state 0
Database system flags 0x3
Page Size 2048 (b)
Date/Time created 01/31/2008 05:29:16
Version number of creator 15
Last modified time stamp 0
Index Page Logging ON since 05/11/2010 14:33:06
HA Disk Owner chisec
Still on Informix 11.10.FC2
I've just again encountered the same error while attempting to restore our
database from a level 0 backup to a new development server:
I scp'ed the backup file from our normal daily backups to the dev server and
restored it with
cat CGTInformixBackup.20160212.Thu.L0 | ontape -r -t STDIO
This succeeded.
I then brought the server on-line with
onmode -m
and that succeeded.
Brought the server down with
onmode -ky
Tried to bring it back on-line with
onint
and got the same error message:
10:12:35 IBM Informix Dynamic Server Stopped.
10:12:48 IBM Informix Dynamic Server Started.
10:12:48 Segment locked: addr=0x44000000, size=114050392064
10:12:48 Segment locked: addr=0x1ad1eee000, size=2871296000
Tue Feb 16 10:12:50 2016
10:12:50 pid 13978: can't get real path of
10:12:50 pid 13978: scan_eh_frame(): bad CIE reference
10:13:03 Event alarms enabled. ALARMPROG =
'/opt/IBM/informix/etc/alarmprogram.sh'
10:13:03 Booting Language <c> from module <>
10:13:03 Loading Module <CNULL>
10:13:03 Booting Language <builtin> from module <>
10:13:03 Loading Module <BUILTINNULL>
10:13:11 DR: DRAUTO is 0 (Off)
10:13:11 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
10:13:11 Event notification facility epoll enabled.
10:13:12 IBM Informix Dynamic Server Version 11.10.FC2 Software Serial Number
AAA#B000000
10:13:12 Can not initialize SDS -
SDS_ENABLE is not set, but the rootchunk indicates a shared disk environment
10:13:12 IBM Informix Dynamic Server Stopped.
10:13:12 mt_shm_remove: WARNING: may not have removed all/correct segments
Last time I ended up adding the new servers in as RSS, then switching them to
HDR secondary.
I want a standalone database in the case so I'll try to do the RSS and then
switch to standalone.
The bigger issue at hand, though, is I have not been able to successfully
restore an informix database from a level 0 backup and that scares me.
I'm taking these backups on the production server with:
ontape -v -s -L 0 -t STDIO | ssh $REMOTE_SERVER " gzip >
$REMOTE_STORE/$BACKUP_FILENAME.gz"
I'd sure appreciate a sanity check on this--if we had a true catastrophic
failure I'm not convinced I could successfully restore the database and have
it remain accessible past the first stop/restart cycle.
Thanks!
Jeff Ross
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g