Enterprise Repication problems
Posted in 2000
Topics: General Discussion
I am trying replication with 2 servers (one NT Database server on a Windows NT 4.0 Workstation, and one UNIX Database server on a Unix SVR4 system). I have been able to start the Windows NT server (g_on_s176) succesfully as a SYNCHRONIZATION server, but I can't start the second server. I am using g_on_s176 as sync server for the UNIX server (g_on_dev2). I received this message defining a second server in Enterprise Replaction (using RM and also using the define_serv API): CDR connection to server lost, id 1, name <g_on_dev2> -- Marking as DOWN Reason: Dharma recv after send failed with rc: -25582 CDR GC: synchronization failed (GC SYNC: incomplete sync not active: 5) ... The server initialisation process fails with a message like: "The start of the server g_on_dev2 failed with error 47 (invalid server name)" Any idea? I don't understand what is going on!! Thank for any help or suggestions, Wim Van Poelvoorde UNISYS Belgium
When a server is first defined, the syscdr database is 'synced' up with one of the existing non-leaf servers. This is the -S option on the cdr command line. What has probably happened is that the SQLHOST portion of the NT registry information is not set up correctly. Either that or there is some inconsistency between the NT and UNIX servers. You were able to establish connectivity between the NT and also were able to make a request to the UNIX server to sync up the syscdr databases. However, there was some type of inconsistency between the sqlhost information between the two systems which caused the 47 error. That in turn caused the initial syncing of the two databases to fail during the network connect process. (The Dharma exchange is part of the communication initialization protocol process.) I would suggest getting in touch with tech support. There is an undocumented support tool that can aid in the population of the NT registry information. It might be useful for the initial ER setup on UNIX/NT environments. Informatica <Informatica@acv-csc.be> wrote in message news:5bdJ4.1$m66.122@nreader3.kpnqwest.net... > I am trying replication with 2 servers (one NT Database server on a Windows > NT 4.0 Workstation, and one UNIX Database server on a Unix SVR4 system). I > have been able to start the Windows NT server (g_on_s176) succesfully as a > SYNCHRONIZATION server, but I can't start the second server. I am using > g_on_s176 as sync server for the UNIX server (g_on_dev2). > > I received this message defining a second server in Enterprise Replaction > (using RM and also using the define_serv API): > > CDR connection to server lost, id 1, name <g_on_dev2> -- Marking as DOWN > Reason: Dharma recv after send failed with rc: -25582 > CDR GC: synchronization failed (GC SYNC: incomplete sync not active: 5) > ... > > The server initialisation process fails with a message like: > > "The start of the server g_on_dev2 failed with error 47 (invalid server > name)" > > Any idea? I don't understand what is going on!! > > Thank for any help or suggestions, > > Wim Van Poelvoorde > UNISYS Belgium > >