Re: Cannot start 2 instances of OnLine 7.x
Posted in 1997
Erik A. Widholm (ewidholm@moody.edu) wrote:
: Until recently, we ran our test database on OL 7.x and our production
: database on OL 5.x with no memory conflicts. Then I upgraded the 5.x to
: 7.x (dbexport, dbimport, etc.), and got it running. During the upgrade,
: I did not have the 7.x engine running, but I did have a level 0 archive
: of it that had been successfully restored a couple of times.
: Now that my production database is up, I cannot get my test engine to
: come up. When I do an 'oninit', it returns to the command prompt OK,
: but within seconds states: oninit: Fatal error in shared memory
: initialization
Most common reasons for this situation:
- Non-unique SERVERNUMs (but this is not your problem, because you would
get shmget[EEXIST] errors or something like that.
- Shared memory kernel parameters not set high enough for two instances.
- Non-unique servicenames or servernames. DSA creates files in /INFORMIXTMP
for your shmem and tcp connections (I don't know about others), which are
named by servicename (for tcp) and servername (for shmem). If these are not
unique on the machine, one will overwrite the other.
Hope that helps.
June
---- June Tong Informix Software ----
---- Senior Consultant (650) 926-6140 ----
---- International Support junet@informix.com ----
---- Location-du-jour: Ashford, England ----
*
* Standard disclaimers apply
*
- Please do not send me requests/questions by mail. When I have the knowledge
- and time permits, I try to answer questions on comp.databases.informix, but
- travel schedule, time, and volume make responding to personal requests
- difficult and often slow. Please call your local Informix Technical Support
- organization for assistance with technical issues.