Port designations
Posted in 1999
Topics: Installation, Setup & Upgrades, Error Codes & Troubleshooting, Server Administration, Networking & sqlhosts Configuration, Platform-Specific Issues, Versions, Editions & End-of-Life
While installing IDS 7.30.UC2 on Solaris 2.6 on x86, we encountered a
failure when initializing the instance with the following error messages
in the Informix message file:
11:28:37 listener-thread: err = -25572: oserr = 0: errstr = : Networkdriver cannot bind a name to the port.
11:28:37 Attempting to bring listener thread down
11:28:37 PANIC: Attempting to bring system down
The sqlhosts file was correctly configured, referencing the right
instance/protocol/server/service. DBSERVERNAME, SERVERNUM and NETTYPE
were set correctly in the ONCONFIG file. In /etc/services, service
"ifmx_tcp" used port "tcp/1525". It wasn't until the port number was
changed -- to 1526 -- and the box rebooted that Informix came up
normally. Port 1525 wasn't defined elsewhere in the file.
Why didn't the original port number work? Why did resetting it work?
Is there a way to get Unix to tell me what ports are currently active?
Is there a way to "remap" the ports without rebooting e.g., by
re-instantiating inet.d?
tia
Red,
Check the file called /etc/inetd.conf -- this file tells you which tcp
services are enabled.
Check man pages for "netstat"....try "netstat -a" to see what ports are
services are listening and established.
And yes, there is a way to remap the ports without rebooting. When inetd
starts up, it creates a file called /etc/inetd.pid which has inetd's process
id. After changing the port number in /etc/services, issue a "kill -1
<pid>" ...where <pid> is the inetd process id from /etc/inetd.pid. This
will issue a SIGHUP signal to the inetd process.
Hope this works.
June A. N.
Red Valsen wrote:
> While installing IDS 7.30.UC2 on Solaris 2.6 on x86, we encountered a
> failure when initializing the instance with the following error messages
> in the Informix message file:
>
> 11:28:37 listener-thread: err = -25572: oserr = 0: errstr = : Network> driver cannot bind a name to the port.
> 11:28:37 Attempting to bring listener thread down
> 11:28:37 PANIC: Attempting to bring system down>
> The sqlhosts file was correctly configured, referencing the right
> instance/protocol/server/service. DBSERVERNAME, SERVERNUM and NETTYPE
> were set correctly in the ONCONFIG file. In /etc/services, service
> "ifmx_tcp" used port "tcp/1525". It wasn't until the port number was
> changed -- to 1526 -- and the box rebooted that Informix came up
> normally. Port 1525 wasn't defined elsewhere in the file.
>
> Why didn't the original port number work? Why did resetting it work?
> Is there a way to get Unix to tell me what ports are currently active?
> Is there a way to "remap" the ports without rebooting e.g., by
> re-instantiating inet.d?
>
> tia
Red,
Check the file called /etc/inetd.conf -- this file tells you which tcp
services are enabled.
Check man pages for "netstat"....try "netstat -a" to see what ports are
services are listening and established.
And yes, there is a way to remap the ports without rebooting. When inetd
starts up, it creates a file called /etc/inetd.pid which has inetd's process
id. After changing the port number in /etc/services, issue a "kill -1
<pid>" ...where <pid> is the inetd process id from /etc/inetd.pid. This
will issue a SIGHUP signal to the inetd process.
Hope this helps.
June A. N.
Red Valsen wrote:
> While installing IDS 7.30.UC2 on Solaris 2.6 on x86, we encountered a
> failure when initializing the instance with the following error messages
> in the Informix message file:
>
> 11:28:37 listener-thread: err = -25572: oserr = 0: errstr = : Network> driver cannot bind a name to the port.
> 11:28:37 Attempting to bring listener thread down
> 11:28:37 PANIC: Attempting to bring system down>
> The sqlhosts file was correctly configured, referencing the right
> instance/protocol/server/service. DBSERVERNAME, SERVERNUM and NETTYPE
> were set correctly in the ONCONFIG file. In /etc/services, service
> "ifmx_tcp" used port "tcp/1525". It wasn't until the port number was
> changed -- to 1526 -- and the box rebooted that Informix came up
> normally. Port 1525 wasn't defined elsewhere in the file.
>
> Why didn't the original port number work? Why did resetting it work?
> Is there a way to get Unix to tell me what ports are currently active?
> Is there a way to "remap" the ports without rebooting e.g., by
> re-instantiating inet.d?
>
> tia
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts