SQL Server using Informix-4GL
Posted in 2007
Topics: Connectivity: ODBC / JDBC / .NET, Connectivity: ESQL/C, 4GL & Embedded SQL
Our application uses SQL Server as backend Database. Some times this error occurs when the background processes are running. [Microsoft][ODBC SQL Server Driver][SQL Server]Could not continue scan with NOLOCK due to data movement. Any one faced such problem. Please clarify.
SQL Server version ? Are you using link server or just DSN ? Looks like T-SQL is using a table level hint. There are some restrictions on table hints e.g. won't work with computed columns etc. Are you using "SET TRANSACTION ISOLATION LEVEL READ UNCOMMITTED"? Best is not to use "NOLCOK" hint and fix underlying issue. Cheers. RAMAKRISHNA RAO <ramakrishnar_rao@hotmail.com> wrote: Our application uses SQL Server as backend Database. Some times this error occurs when the background processes are running. [Microsoft][ODBC SQL Server Driver][SQL Server]Could not continue scan with NOLOCK due to data movement. Any one faced such problem. Please clarify. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. --------------------------------- Sucker-punch spam with award-winning protection. Try the free Yahoo! Mail Beta.
Rao, This behavior may occur when a row in a table is deleted between the time SQL Server reads the location of the row from an index and the time SQL Server fetches the row. What version and SP level is your SQL server running? Microsoft KB article notes: To resolve this problem, obtain the latest service pack for Microsoft SQL Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base 290211. Here are both of the links: http://support.microsoft.com/kb/815008 http://support.microsoft.com/kb/290211/ -----Original Message----- From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of RAMAKRISHNA RAO Sent: Tuesday, June 12, 2007 12:50 AM To: ids@iiug.org Subject: SQL Server using Informix-4GL [9333] Our application uses SQL Server as backend Database. Some times this error occurs when the background processes are running. [Microsoft][ODBC SQL Server Driver][SQL Server]Could not continue scan with NOLOCK due to data movement. Any one faced such problem. Please clarify. ************************************************************************ ******* Forum Note: Use "Reply" to post a response in the discussion forum.
1. I would run PROFILER to see what's going on. 2. I haven't use 4GL but at database level using SQL, you can certainly control ISOLATION levels Cheers.. Ramakrishna Rao <ramakrishnar_rao@hotmail.com> wrote: P { margin:0px; padding:0px } body { FONT-SIZE: 10pt; FONT-FAMILY:Tahoma } Thanks for your reply The application uses SQL Server version - 8.00 and connect through ODBC. For User Interface we uses Querxi tools and we didn't mentioned any ISOLATION levels in Informix-4GL level. Can we control the same in Informix-4GL. Thanks Ramakrishna Rao. --------------------------------- > To: ramakrishnar_rao@hotmail.com > From: hariog@yahoo.com > Subject: Re: SQL Server using Informix-4GL [9336] > Date: Tue, 12 Jun 2007 05:56:46 -0400 > > SQL Server version ? Are you using link server or just DSN ? > Looks like T-SQL is using a table level hint. There are some restrictions on > table hints e.g. won't work with computed columns etc. > > Are you using "SET TRANSACTION ISOLATION LEVEL READ UNCOMMITTED"? > Best is not to use "NOLCOK" hint and fix underlying issue. > > Cheers. > RAMAKRISHNA RAO <ramakrishnar_rao@hotmail.com> wrote: > Our application uses SQL Server as backend Database. Some times this error > occurs when the background processes are running. > > [Microsoft][ODBC SQL Server Driver][SQL Server]Could not continue scan with > NOLOCK due to data movement. > > Any one faced such problem. > Please clarify. > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --------------------------------- > Sucker-punch spam with award-winning protection. > Try the free Yahoo! Mail Beta. > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. --------------------------------- Sign in and get updated with all the action! Formula One --------------------------------- Ready for the edge of your seat? Check out tonight's top picks on Yahoo! TV.