Confusing 674: Routine (filetoblob) can not be resolved error
Posted in 2004
Topics: General Discussion
IBM Informix Dynamic Server Version 9.40.UC2
Linux 2.4.18-14
I'm having trouble running the following statement:
INSERT INTO genrequest(datefor, status, regions, sourceip)
VALUES (TODAY, 0, filetoblob('/var/tmp/dbtmp.13', 'server','regions'), "ipc");
I get the 674 error mentioned in the subject. Do I have to do anything
special to get the handling of blobs enabled? Reading the manual has
given me no clues as to why it does not work, nor does the release
notes. Can anyone shed any light on this?
Cheers
Richb
Rich Blee wrote:
> IBM Informix Dynamic Server Version 9.40.UC2
>
> Linux 2.4.18-14
>
> I'm having trouble running the following statement:
>
> INSERT INTO genrequest(datefor, status, regions, sourceip)
> VALUES (TODAY, 0, filetoblob('/var/tmp/dbtmp.13', 'server',> 'regions'), "ipc");
>
> I get the 674 error mentioned in the subject. Do I have to do anything
> special to get the handling of blobs enabled? Reading the manual has
> given me no clues as to why it does not work, nor does the release
> notes. Can anyone shed any light on this?
Just a guess, but have you tried using either just two or all four
parameters? The documentation does note that the 'table' and 'column'
parameters are optional, but maybe the 'and' is the key to it. Your example
shows that you are using just three parameters for the FILETOBLOB function,
and the -674 error says one of the problems may be too few parameters. As I
said - it is just a guess.
--
June Hunt
Very good response, June. If you do a "select procname, paramtypes from
sysprocedures where procname = "filetoblob", you'll get...
C:\\Informix>dbaccess stores_demo -
Database selected.
> select procname, paramtypes from sysprocedures
> where procname = "filetoblob";
procname filetoblob
paramtypes lvarchar,char
procname filetoblob
paramtypes lvarchar,char,char,char
2 row(s) retrieved.
>
"June C. Hunt" <june_c_hunt@hotmail.com> wrote in message
news:2p3ibfFftud9U1@uni-berlin.de...
> Rich Blee wrote:
> > IBM Informix Dynamic Server Version 9.40.UC2
> >
> > Linux 2.4.18-14
> >
> > I'm having trouble running the following statement:
> >
> > INSERT INTO genrequest(datefor, status, regions, sourceip)
> > VALUES (TODAY, 0, filetoblob('/var/tmp/dbtmp.13', 'server',> > 'regions'), "ipc");
> >
> > I get the 674 error mentioned in the subject. Do I have to do anything
> > special to get the handling of blobs enabled? Reading the manual has
> > given me no clues as to why it does not work, nor does the release
> > notes. Can anyone shed any light on this?
>
> Just a guess, but have you tried using either just two or all four
> parameters? The documentation does note that the 'table' and 'column'
> parameters are optional, but maybe the 'and' is the key to it. Your
example
> shows that you are using just three parameters for the FILETOBLOB
function,
> and the -674 error says one of the problems may be too few parameters. As
I
> said - it is just a guess.
>
> --
> June Hunt
>
>
That was it exactly. Good call! Only problem now is that because it's a
TEXT type, there's no way of doing what I want to do. How I cursed the guy
who did that!
Onto plan B!
On Wed, 25 Aug 2004 09:26:05 -0400, June C. Hunt uttered forth:
> Rich Blee wrote:
>> IBM Informix Dynamic Server Version 9.40.UC2
>>
>> Linux 2.4.18-14
>>
>> I'm having trouble running the following statement:
>>
>> INSERT INTO genrequest(datefor, status, regions, sourceip)
>> VALUES (TODAY, 0, filetoblob('/var/tmp/dbtmp.13', 'server',>> 'regions'), "ipc");
>>
>> I get the 674 error mentioned in the subject. Do I have to do anything
>> special to get the handling of blobs enabled? Reading the manual has
>> given me no clues as to why it does not work, nor does the release
>> notes. Can anyone shed any light on this?
>
> Just a guess, but have you tried using either just two or all four
> parameters? The documentation does note that the 'table' and 'column'
> parameters are optional, but maybe the 'and' is the key to it. Your example
> shows that you are using just three parameters for the FILETOBLOB function,
> and the -674 error says one of the problems may be too few parameters. As I
> said - it is just a guess.
>
> --
> June Hunt