Re: OpenServer 5.0 / Informix password bug?
Posted in 1998
We had similar problems a long time ago with passwords that where
longer than 8 characters. It's easy to test at least.
On Tue, 10 Mar 1998 20:05:52 -0600, Jay Hannah <jhannah@mammoth.org>
wrote:
>Greetings --
>
>SCO OpenServer 5.0
>DB-Access Version 7.20.UC5
>Windows 95 ODBC 3.0.23.1 (shouldn't matter?)
>
>Can anyone explain the following behavior?
>---
>1) ODBC to Informix works find with user "jhannah", password "1stPW".
>2) Telnet to OpenServer, change passwd jhannah to "DifferentPW".
>3) ODBC to Informix errors:
> [Informix][sqlinfmx.dll] SQL Error (-952):
> User's password is not correct for the database server.
>4) (ODBC with old password gives the same error -- as expected)
> Shut down oninit, start it back up.
>5) ODBC to Informix gives the same error.
>6) Hmmm... Reboot OpenServer.
>7) ODBC to Informix gives the same error.
>8) Telnet to OpenServer, change passwd jhannah back to "1stPW".
>9) ODBC to Informix works fine.
>--
>
>Is this a bug? Can I *never* change passwords on users I want to be able
>to use ODBC?
>
>Perplexed,
>
>Jay
Nils Myklebust
NM Data AS
Norway
E-mail: Nils.Myklebust@nmdata.com
FAQ at: Primary with ODBC info: http://www.smooth1.demon.co.uk
Official site http://www.iiug.org/techinfo/faq/faq_top.html